Learning Objectives

After completing this chapter, you will be able to:

• Use the Brush Tool to apply paint to an image.
• Compare the effects of different blending modes.
• Use the Brush Preset Picker and the Brushes panel to select and modify brush styles.
• Compare the Image Size and Canvas Size commands.
• Use the Pattern Stamp Tool to paint patterns in an image.
• Use the Pattern Picker to select and organize patterns.
• Explain the difference between the Brush Tool and Pencil Tool.
• Use the Eyedropper Tool to sample a color in an image.
• Use the Gradient Tool to create different styles of gradients.
• Use the Gradient Editor to edit a gradient.
• Use the Paint Bucket Tool to fill an area with color.
• Use the tools found in the Liquify filter to manipulate an image.

Introduction

You have probably used a simple painting program on a computer. Most painting programs allow you to spread color on your screen with a variety of tools, such as a paintbrush, a pencil, or a paint bucket. Photoshop's painting tools have an incredible amount of brush styles to choose from. There are brushes that imitate any traditional art style that you can think of. There are square brushes, calligraphy brushes, and special effect brushes that let you paint anything from stars to grass, Figure 6-1. You can even create your own brushes, or download brushes created by other artists.

Photoshop's painting tools are used for more than just painting color on your screen. For example, in Chapter 3, Selection Tools, you learned that while in quick mask mode, the Brush Tool is used to create a mask. The shape and size of many of Photoshop's other tools are controlled by choosing from the same assortment of brushes used by the Brush Tool.

Photoshop offers more than one hundred filters. Filters are special effects that can be applied to all or part of a file. For example, one filter makes an image look like it is coated with plastic wrap, another modifies an image so it looks like a stained glass window, and another causes a photo to appear as if it was created by an artist using colored pencils.

The Brush Tool

The primary function of the Brush Tool is to paint with the foreground color shown in the Tools panel. Painting occurs as you might expect: by clicking and dragging the mouse or using a graphics tablet. Straight lines can also be created with this tool if you click the start point, then press [Shift] and click the end point of the line. If you want to add additional segments to the existing line, continue clicking points while holding [Shift]. If you want to start an entirely new line, release the [Shift] key, click the new starting point, then press and hold [Shift] and click the desired end point.

The options that appear on the Brush Tool's options bar are also found on the options bar of several other painting tools. See Figure 6-2. The current brush size (its diameter, in pixels) and style are shown. Next to it is a small, downward-pointing arrow that opens the Brush Preset Picker. The Brush Preset Picker is used to change the size and style of the brush. Since brush sizes are usually changed frequently while you work, you may find it more convenient and quicker to change brush sizes by pressing
the bracket keys ( [ , ] ) instead of using the Brush Preset Picker. The right bracket ( ] ) decreases it. Another method is to press and hold [Alt] and then right-click and drag the mouse to resize the brush (Mac users hold down [Ctrl][Option] while clicking and dragging the mouse). Since pressing the [Alt] key activates the Color Sample Tool, you must be careful not to inadvertently sample a new color before right-clicking.

The Mode setting lets you choose from several blending modes. Blending modes control the way the brush color blends with the image beneath it. Because there is a long list of modes, they will be explained a bit later in this chapter.

The Opacity setting determines how solid (opaque) the paint appears. An Opacity setting of 100% means you will not be able to see through the paint that the brush leaves behind. Entering a lower percentage causes the paint to appear less solid. A value of 1% in this setting results in paint that is very nearly transparent.

When using a lower Opacity setting, you can get different results if your painting strokes overlap. If you release the mouse button as you paint several strokes, the paint will appear darker where the overlap occurs. See Figure 6-3. Holding down the mouse button continuously as you paint avoids this effect.

The Flow setting determines how much paint is deposited in the image at any given time. If the Flow setting is lower than 100%, the amount of paint produced by the Brush Tool is restricted. For example, if the Flow setting is changed from 100% to 50%, only half as much paint will be produced by the Brush Tool.

Clicking the airbrush button causes the Brush Tool to act like an airbrush. An airbrush forces paint through a nozzle using compressed air. This setting causes paint to keep spraying out as long as you are holding down the mouse button. You will really notice this effect if you move the mouse very slowly or stop moving it while you paint.

At the far right of the options bar is the Brushes panel toggle. Activating this toggle displays the Brushes panel. The settings in the Brushes panel are more detailed than those in the Brush Preset Picker.

The Brush Preset Picker

The Brush Preset Picker displays when you click on the small downward-pointing arrow on the options bar. See Figure 6-4. From the Brush Preset Picker, you can quickly change the size (diameter) and hardness of the brush. The Hardness setting controls how sharp and crisp the edge of the brush looks. A setting of 0% produces a soft, feathery edge.

Figure 6-3
When the Opacity setting is less than 100%, painting in one continuous stroke does not cause a darkened overlap effect (left). Releasing the mouse button and then painting additional strokes darkens the paint in areas that overlap (right).

Figure 6-4
The Brush Preset Picker is used to change the size and hardness of the brush.

The Brush Preset Picker Menu

The Brush Preset Picker menu is structured just like the Custom Shape Picker menu that you learned about in Chapter 5. Text, Shapes, and Layer Styles. Most of Photoshop’s picker menus are structured in the same way. See Figure 6-5.

The New Brush Preset command lets you save your current settings as a new brush in the Brush Preset Picker. This command is identical in function to the Create a new preset from this brush button in the picker. After it is named, the new preset appears at the bottom of the list of available presets in the picker.

The two commands in the next section of the menu allow you to delete and rename presets. To rename a brush preset, select the preset in the Brush Preset Picker and then select Rename Brush from the Brush Preset Picker menu. To delete a preset, select the brush in the picker and then choose Delete Brush from the Brush Preset Picker menu.
The third section of the menu lists several ways the brushes can be displayed in the picker. The Stroke Thumbnail option is the most informative because you can see a sample brush stroke along with the small thumbnail image of the brush tip.

Choosing the Preset Manager command opens the Preset Manager dialog box. This dialog box displays all of the brushes that are currently in the picker. You can use the Preset Manager to delete and load different brushes, if desired.

Choosing the Reset Brushes command restores the picker to its default state. When you modify brushes, you can use the Save Brushes command to save the current condition of the Brush Preset Picker to a file. This file can be retrieved later by using the Load Brushes command. The Replace Brushes command is very similar to the Load Brushes command. The difference is the old brushes are replaced (deleted) instead of appended (added to) as the new brushes are loaded into the picker.

The last section of the menu lists all of the available brush categories. When you click one of these categories, a dialog box asks if you want to replace or append the current brushes. If you click OK, the new brushes are added, but all of the brushes that were previously in the picker are deleted. If you click Append, the new brushes are added to the brushes already listed in the picker.

**Brush Tool Blending Modes**

Remember the Mode setting on the Brush Tool’s options bar? Blending modes control how the Brush Tool behaves when adding color to an image. You will find these same modes on the options bar of several other painting tools (although some modes are not available with certain tools). Modes are also found on the Layers panel and control how layers blend with one another. This is discussed further in Chapter 11, *Additional Layer Techniques*.

The blending modes available with the Brush Tool are briefly explained in Figure 6-6. The examples that appear in the table show the result of using a soft, round brush with a medium blue color as the foreground color. The Opacity setting is 100% in all examples. As you read about the modes in Figure 6-6, remember that you should always create a duplicate layer before painting an image so that the original image is always preserved. Your results will vary depending on the color of the original image and the color of the paint. You should also be aware that using black and white paint with blending modes creates unpredictable results.

**The Brushes Panel**

The Brushes panel contains many more options than the Brush Preset Picker. From this panel, you can customize brushes in a variety of ways. The Brushes panel can be displayed by clicking the Toggle the Brushes panel button on the options bar or by choosing Window > Brushes.

The Brushes panel contains a panel menu that is similar to the menu found on the Brush Preset Picker, except it contains more commands. When the Expanded View option is selected, the Brushes panel appears as shown in Figure 6-7. When the Expanded View option is not enabled, the Brushes panel looks very similar to the Brush Preset Picker.

When the Brushes panel is open in expanded view, the section on the left displays the different categories of controls that can be adjusted in the panel. Clicking on one of these categories places a check mark in its check box to show that it is active. The various options available for the selected category of controls are displayed on the right side of the panel. A preview window at the bottom of the panel shows the effects the current settings will have on the brush strokes.
The Brush Tip Shape Settings

When the **Brush Tip Shape** entry is clicked in the left section of the panel, the right side of the panel displays each brush tip that is currently loaded. Here, you can change the brush diameter or flip or rotate the brush tip, and adjust the spacing between brush marks.

### Mode and Explanation

<table>
<thead>
<tr>
<th>Mode and Explanation</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>(From left to right) <strong>Lighten</strong>, <strong>Screen</strong>, <strong>Color Dodge</strong>, <strong>Linear Dodge</strong>, and <strong>Lighter Color</strong> modes cause the paint color to lighten the image in different ways. Again, refer to Photoshop’s help file if you would like an explanation of the differences between each mode.</td>
<td><img src="example1.png" alt="Example" /></td>
</tr>
<tr>
<td>(From left to right) <strong>Overlay</strong>, <strong>Soft Light</strong>, <strong>Hard Light</strong>, <strong>Vivid Light</strong>, <strong>Linear Light</strong>, <strong>Pin Light</strong>, and <strong>Hard Mix</strong> are found in the next section of the <strong>Mode</strong> drop-down menu. Most of these modes will either darken or lighten pixels below it, depending on how dark or light the blend color (the color you are painting) is. The final results are computed in a slightly different manner for each of these modes.</td>
<td><img src="example2.png" alt="Example" /></td>
</tr>
<tr>
<td>The <strong>Difference</strong> (left) and <strong>Exclusion</strong> (right) modes are similar. They create a lighter effect because they subtract the base and blend colors from each other.</td>
<td><img src="example3.png" alt="Example" /></td>
</tr>
<tr>
<td>(From left to right) The <strong>Hue</strong> mode changes an object’s color while preserving shadows and highlights (light areas). <strong>Saturation</strong> mode changes the saturation, or intensity, of an object’s color. <strong>Color</strong> and <strong>Luminosity</strong> modes are opposite of each other. These modes combine characteristics of the base color with the blend color.</td>
<td><img src="example4.png" alt="Example" /></td>
</tr>
</tbody>
</table>

### Shape Dynamics Settings

When the **Shape Dynamics** entry is clicked on the left side of the panel, the right side of the panel displays a group of settings that are used to add some variance to the brush stroke. The shape dynamics settings can be used in combinations to achieve the desired result.

**Click to access the panel menu**

**The Expanded View option is active**

In the example in Figure 6-8, one of the special effect brushes, **Dune Grass**, is selected and its spacing has been changed so that fewer grass clumps are generated while painting. The individual patterns of paint created by the brush, in this case clumps of grass, are referred to as **brush marks**. When a paint tool is being used, brush marks are created at regular intervals in the brush stroke. These intervals are called **steps**. The **Spacing** setting determines the distance between steps in the brush stroke. A path with steps that are closer together will look more solid or continuous than a stroke in which the steps are spaced widely apart. In other words, you could create a dashed line effect by controlling the **Spacing** setting. The example you see at the bottom of the **Brushes** panel shows how the brush stroke will appear as you click and drag with the mouse.

**Learning Photoshop**

**Figure 6-7.** The **Brushes** panel (shown in expanded view) and its panel menu.

**The Expanded View option is active.**

In the example in Figure 6-8, one of the special effect brushes, **Dune Grass**, is selected and its spacing has been changed so that fewer grass clumps are generated while painting. The individual patterns of paint created by the brush, in this case clumps of grass, are referred to as **brush marks**. When a paint tool is being used, brush marks are created at regular intervals in the brush stroke. These intervals are called **steps**. The **Spacing** setting determines the distance between steps in the brush stroke. A path with steps that are closer together will look more solid or continuous than a stroke in which the steps are spaced widely apart. In other words, you could create a dashed line effect by controlling the **Spacing** setting. The example you see at the bottom of the **Brushes** panel shows how the brush stroke will appear as you click and drag with the mouse.

**Figure 6-7.** The **Brushes** panel (shown in expanded view) and its panel menu.

In the example in Figure 6-8, one of the special effect brushes, **Dune Grass**, is selected and its spacing has been changed so that fewer grass clumps are generated while painting. The individual patterns of paint created by the brush, in this case clumps of grass, are referred to as **brush marks**. When a paint tool is being used, brush marks are created at regular intervals in the brush stroke. These intervals are called **steps**. The **Spacing** setting determines the distance between steps in the brush stroke. A path with steps that are closer together will look more solid or continuous than a stroke in which the steps are spaced widely apart. In other words, you could create a dashed line effect by controlling the **Spacing** setting. The example you see at the bottom of the **Brushes** panel shows how the brush stroke will appear as you click and drag with the mouse.

**The Expanded View option is active**

In the example in Figure 6-8, one of the special effect brushes, **Dune Grass**, is selected and its spacing has been changed so that fewer grass clumps are generated while painting. The individual patterns of paint created by the brush, in this case clumps of grass, are referred to as **brush marks**. When a paint tool is being used, brush marks are created at regular intervals in the brush stroke. These intervals are called **steps**. The **Spacing** setting determines the distance between steps in the brush stroke. A path with steps that are closer together will look more solid or continuous than a stroke in which the steps are spaced widely apart. In other words, you could create a dashed line effect by controlling the **Spacing** setting. The example you see at the bottom of the **Brushes** panel shows how the brush stroke will appear as you click and drag with the mouse.

**Figure 6-7.** The **Brushes** panel (shown in expanded view) and its panel menu.

In the example in Figure 6-8, one of the special effect brushes, **Dune Grass**, is selected and its spacing has been changed so that fewer grass clumps are generated while painting. The individual patterns of paint created by the brush, in this case clumps of grass, are referred to as **brush marks**. When a paint tool is being used, brush marks are created at regular intervals in the brush stroke. These intervals are called **steps**. The **Spacing** setting determines the distance between steps in the brush stroke. A path with steps that are closer together will look more solid or continuous than a stroke in which the steps are spaced widely apart. In other words, you could create a dashed line effect by controlling the **Spacing** setting. The example you see at the bottom of the **Brushes** panel shows how the brush stroke will appear as you click and drag with the mouse.

**Figure 6-7.** The **Brushes** panel (shown in expanded view) and its panel menu.

In the example in Figure 6-8, one of the special effect brushes, **Dune Grass**, is selected and its spacing has been changed so that fewer grass clumps are generated while painting. The individual patterns of paint created by the brush, in this case clumps of grass, are referred to as **brush marks**. When a paint tool is being used, brush marks are created at regular intervals in the brush stroke. These intervals are called **steps**. The **Spacing** setting determines the distance between steps in the brush stroke. A path with steps that are closer together will look more solid or continuous than a stroke in which the steps are spaced widely apart. In other words, you could create a dashed line effect by controlling the **Spacing** setting. The example you see at the bottom of the **Brushes** panel shows how the brush stroke will appear as you click and drag with the mouse.

**Figure 6-7.** The **Brushes** panel (shown in expanded view) and its panel menu.
Available brush tips
Spacing between brush marks is increased
Preview of new settings

Figure 6-8. The design, diameter, orientation, and spacing of brush tips can be changed in the Brush Tip Shape section of the Brushes panel.

Figure 6-9. The size jitter effect in Shape Dynamics section of the Brushes panel can be used to introduce some variation into the size of the brush marks making up the brush stroke. A preview of how the brush will paint appears at the bottom of the Brushes panel.

The stroke tapers down from full size to 25% over the first 28 brush marks
Brush marks vary in size from full size to 25% (Minimum Diameter setting)
The size jitter effect is applied to only the first 28 brush marks
All brush marks will be at least 25% of full brush size

The remaining brush marks in the stroke are reduced to 25% (Minimum Diameter setting)

Maximum size of brush marks tapers down from full size to 25%—the size jitter effect is applied to only these brush marks

Each brush mark can vary from its normal position by up to 36°, or 10% of 360°. The first 15 brush marks are rotated in increasing amounts—the angle jitter effect is added to this base rotation
The first 15 brush marks are rotated in increasing increments of 24°, ending with a complete rotation
The remaining brush marks are affected only by the angle jitter effect

Note
If the Size Jitter setting is higher than the Minimum Diameter setting, the Minimum Diameter setting determines how much the brush marks can vary in size.

The Control drop-down list offers a few options for varying the stroke width. Only the Off and Fade options work without a pressure-sensitive tablet and stylus. When the Off option is selected, the maximum stroke width remains constant and the size jitter effect is applied to the entire stroke. When the Fade option is selected, the maximum width of the stroke tapers down from full size down to the minimum size over the number of steps (increments) specified in the text box to the right of the Control drop-down list.

The Fade option also causes the size jitter effect to gradually diminish over the specified number of steps. Beyond the specified number of steps, the size jitter effect is not applied because all brush marks are already at their minimum allowable size.

The Minimum Diameter slider determines the minimum width that a brush mark is allowed to be. The value set with this slider represents a percentage of the full brush size.

The Angle Jitter setting causes random fluctuation in the angles of the steps (grass clumps). The Control drop-down list below the Angle Jitter slider provides several options for applying the angle jitter effect and for changing the angles of stroke marks, only a few of which are available without a pressure-sensitive tablet and stylus. The Initial Direction and Direction options subtly change the way the angle jitter effect is applied. When the Fade option is selected, the brush marks are progressively rotated from 0° to 360° over the specified number of steps. Therefore, if 10 is entered in the text box, the first ten brush marks are rotated in progressive increments of 36°. Beyond the specified number of steps, the angle jitter is applied normally. See Figure 6-10.

The first 15 brush marks are rotated in increasing amounts—the angle jitter effect is added to this base rotation

Figure 6-10. The angle jitter effect randomly tilts brush marks forward and backward.
Roundness jitter changes the perspective of each brush mark. As a brush mark’s roundness setting decreases, it appears as though it is rotated toward the viewer. Figure 6-11. The Roundness Jitter slider sets the amount of variation in the roundness setting of the individual brush marks. The limits of the roundness jitter effect are set with the Minimum Roundness slider, and the roundness setting can gradually be applied using the Fade option in the Control drop-down list. These controls are very similar to their counterparts for the size jitter effect.

Activating the Flip X Jitter check box causes some of the brush marks to be mirrored horizontally. Placing a check mark in the Flip Y Jitter check box causes some of the brush marks to be mirrored vertically. See Figure 6-12.

Scattering Settings

When you click the Scattering entry on the left side of the Brushes panel, a set of controls appear that allow you to adjust how the brush marks are distributed in the area around the brush. Increasing the Scatter setting causes brush strokes to apply paint in a ragged line instead of a straight path. If the Both Axes check box is checked, the brush marks will be scattered above, below, in front, and behind the cursor. If this check box is unchecked, the brush marks are distributed in a straight line perpendicular to the brush path. The Count setting determines the maximum number of brush marks that can be created at each step in the brush stroke. The Count Jitter setting determines how much variation there is in the number of brush marks created. The effect of these settings can be gradually decreased by selecting the Fade option from the Control drop-down lists and entering a number of steps in the text box to the right. See Figure 6-13.

Figure 6-12.
The flip X jitter effect mirrors random brush marks vertically. The flip Y jitter effect mirrors random brush marks horizontally. Some brush marks will be affected by both options.

Figure 6-13.
Increasing the Scattering and Count Jitter settings causes paint to be applied in a more random fashion.
Texture Settings

When you click the Texture entry on the left side of the Brushes panel, a group of controls appears on the right that allow you to combine a texture file with the brush tip. This adds a textured look to the paint. See Figure 6-14. For example, with the right settings, paint can look like it was applied to a real canvas. Using texture files are discussed in more detail in the “Pattern Stamp Tool” section in this chapter.

Clicking the down arrow next to the texture preview opens the pattern picker, from which a pattern is selected for the texture. Activating the Invert check box reverses the effect of the pattern’s color on the resulting texture. The Scale slider setting determines the size of the texture. When the Texture each tip check box is checked, the texture is applied to each brush mark individually, when it is unchecked the texture is applied to the stroke as a whole. The difference between these settings can be subtle.

The Depth settings control to what degree the texture file is combined with the brush stroke. They work together to control the appearance of the image in much the same way as the other groups of controls you have studied in the Brushes panel.

Dual Brush Settings

In the Dual Brush section of the Brushes panel, a second brush tip can be combined with the first. Paint will appear where the two brush tips overlap. Similar to the Texture section, this is another way to increase the complexity of a brush tip.

To use the dual brush option, begin by defining the first brush in the Brushes panel. Once you have selected and adjusted the brush and activated the desired options, click the Dual Brush entry on the left side of the Brushes panel.

Figure 6-14. The controls in the Texture section of the Brushes panel can be used to add a three-dimensional appearance to the brush stroke.

Color Dynamics Settings

The Color Dynamics section of the Brushes panel contains jitter settings that create random color fluctuations. The leaf pattern in Figure 6-16 was created by starting with a leaf-shaped brush and setting orange as the foreground color and brown as the background color. The Hue Jitter was increased very slightly, allowing the leaves to have just a hint of different colors. This produces the occasional leaf that is slightly more green or yellow than the others. A higher setting would cause the brush to occasionally produce colors that are not as closely related to the selected foreground and background colors, such as a bright blue or magenta. The Saturation Jitter and Brightness Jitter settings were also

Figure 6-15. The controls in the Dual Brush section of the Brushes panel are used to combine two different brushes to create a single stroke. Paint is only applied to the areas where the two brushes overlap.
Figure 6-16. A leaf pattern was painted in only a few seconds. The jitter and scattering effects create a naturally random look to the leaves.

The **Pencil Tool** appears to paint with a varying blend of foreground and background colors. This is similar to how the **Pencil Tool** can “erase” what you have painted, but it does not actually delete any pixels. Instead, it paints the background color on top of areas you have painted with the foreground color. This is similar to how the **Eraser Tool** works on a locked layer.

The **Protect Texture** option only works, however, if **Auto Erase** works on a locked layer. The **Smoothing** option is on, the **Curves** panel menu.

The **Hardness** slider setting adjusts the saturation for all of the color created by the **Brush Tool**. The **Smoothing** slider setting just sets the variation.

The **Shape Dynamics** and other entries already discussed. Rather, these are single options that are always available, no matter what other settings have been changed.

Activating the **Noise** option creates a blotching effect in the soft areas of the brush. This effect could simulate the type of spray pattern that comes from a can of spray paint that has not been shaken enough.

Turning on the **Wet Edges** option causes the paint to thin out (become somewhat transparent) in the center of the brush stroke and pool at the edges. This effect could be used to simulate excessively thinned paint, watercolors, or a coffee stain.

The **Airbrush** option, when activated, causes the brush to continue to lay down paint as long as the mouse button is held. This option works the same as its counterpart on the options bar.

When the **Smoothing** option is activated, the curves in the brush stroke are smoothed out. This option is most noticeable when you are painting with a pressure-sensitive tablet and stylus.

If you have adjusted the texture settings on various brushes, the **Protect Texture** option forces any of these brushes to use the same scale and pattern settings. This causes a uniform-looking “canvas” to appear under a painting as you switch from brush to brush.

To reset all of the settings in the **Brushes** panel, choose **Clear Brush Controls** from the **Brushes** panel menu.

**Creating a Custom Brush Tip**

It is simple to create a new brush tip. To create a flower-shaped brush, for example, use either of the following methods. First, you create a new file (3 inches square and 200 pixels per inch are reasonable settings). Using black as your color, use the **Pen Tool** or shape tools to create the flower shape. Rasterize the shape layers, and then convert them to a brush by choosing **Edit > Define Brush Preset…** Name the new flower-shaped brush, and click **OK**. It is added to the **Brush Preset Picker**.

Another method is to select a flower from a photograph. Once the flower is selected (apply a feather effect for smoother edges), convert it into a brush by choosing **Edit > Define Brush Preset…** During this process, Photoshop converts the flower you selected into a grayscale image—an image that controls how the new brush tip applies paint. Parts of the flower that are gray apply paint semi-transparently, depending on how light or dark the shade of gray is. Black parts of the brush apply paint at full strength.

Many custom brush tips are available for free download from websites like Adobe’s Exchange.

**The Pencil Tool**

The **Pencil Tool** is found behind the **Brush Tool** in the **Tools** panel. The **Pencil Tool** is a painting tool that creates a hard-edged brush stroke. It does not matter what the **Hardness** setting is in the **Brush Preset Picker**. In contrast, the **Brush Tool** creates an anti-aliased, softer edge, even when the **Hardness** setting is changed to 100% in the **Brush Preset Picker**.

Compare the two brush strokes in Figure 6-17. The first was created with the **Pencil Tool** with the **Hardness** set at 100%. The second stroke was created with the **Brush Tool** with the **Hardness** set at 100%.

The **Pencil Tool**’s options bar contains options you are already familiar with, plus one more, **Figure 6-18**. When the **Auto Erase** option is on, the **Pencil Tool** can “erase” what you have painted, but it does not actually delete any pixels. Instead, it paints the background color on top of areas you have painted with the foreground color. This is similar to how the **Eraser Tool** works on a locked layer. The **Auto Erase** option only works, however, if
the exact center of your brush is over a painted area before you click the mouse button to erase. The erase mode will continue until you release the mouse button.

Straight lines can be created with the **Pencil Tool** by clicking the starting point, then holding **[Shift]** while clicking the end point of the line.

**Note**
The remaining tool grouped with the **Brush Tool** in the **Tools** panel is the **Color Replacement Tool**. This tool will be discussed in Chapter 9, *Introduction to Color Correction*.

---

**The Pattern Stamp Tool**

The **Pattern Stamp Tool** paints a pattern instead of a solid color. The **Pattern Stamp Tool** is found behind the **Clone Stamp Tool** in the **Tools** panel. The **Clone Stamp Tool** will be discussed in Chapter 8, *Restoring and Retouching Photos*.

**The Pattern Stamp Tool’s Options Bar**

The options bar for the **Pattern Stamp Tool** contains all of the **Brush Tool**’s options, plus a **Pattern Picker**, Figure 6-19. The **Pattern Picker** behaves just like the **Brush Preset Picker**. It contains a panel menu that controls the display of the picker and lets you load, save, replace, or reset patterns. The bottom section of the panel menu lists nine different pattern categories that can be replaced or appended into the **Pattern Picker**.

There are two additional settings on the **Pattern Stamp Tool**’s options bar. When the **Aligned** option is on, the pattern repeats itself over and over, side by side, as you paint it. This is called a **tiled** pattern. If the **Aligned** option is turned off, clicking the mouse occasionally as you paint creates a pattern that does not repeat—or in other words, blends the pattern into itself. Activating the **Impressionist** option causes the **Pattern Stamp Tool** to create brush marks that have the same colors as the pattern, but not the structure of the pattern.

---

**Defining Your Own Patterns**

You can also create your own patterns by opening an image file, selecting part of it with the **Rectangular Marquee Tool**, and choosing **Edit > Define Pattern…**. After you name the pattern and click **OK**, the pattern appears at the end of the list in the **Pattern Picker**.

**The Gradient Tool**

A gradient consists of two or more colors that gradually blend together. Gradients are used to create colorful backgrounds or shapes. They can also be used to create more complex effects, such as shadows or fade-out effects. In this chapter, you will be introduced to the basics of gradients. You will see more examples of advanced gradient effects in a later chapter.

The options bar of the **Gradient Tool** contains the **Gradient Picker**, which functions like Photoshop’s other pickers, Figure 6-20. When the default gradients are loaded in the **Gradient Picker**, the first gradient is always a combination of the foreground and background color, and the second gradient is always a combination of the foreground color and a transparent area. The rest of the gradients are preset colors which can be replaced, deleted, or edited.

You can right-click (Mac: **[Ctrl]** + click) on any gradient and use the shortcut menu that appears to delete, rename, or add a new gradient to the picker. The **Gradient Picker** menu, which is opened by clicking the small arrow at the top right of the **Gradient Picker**, can be used to accomplish the same tasks as the shortcut menu. In addition, the **Gradient Picker** menu lists several categories of preset gradients that can be replaced or appended into the picker. You can also use the **Gradient Picker** menu to save your own collection of gradients so they can be loaded again at a later time.
Before learning about the rest of the Gradient Tool’s options, you need to know how to use the Gradient Tool. Creating a gradient is simple—you drag a line at any angle on your screen and release the mouse button. Dragging a long line creates a more gradual gradient. If you drag a short line, the transition between colors is more abrupt. See Figure 6-21.

In the options bar, you can choose from several styles of gradients by clicking the buttons next to the Gradient Picker. The example in the Figure 6-21 was created with the first gradient style, called Linear Gradient, applied at an angle. Examples of all five gradient styles are shown in Figure 6-22.

When you add a gradient to an image, you can choose from several different blending modes in the Mode drop-down list. You can control how transparent the gradient is by changing the Opacity setting.
The Reverse option switches the gradient colors. In Figure 6-23, a two-color gradient (green and blue) was applied to a custom shape. Before the Gradient Tool would work, each shape layer had to be rasterized and selected.

The Dither option should be left on in most cases. It blends the gradient by adding “noise,” making it appear smoother. Some gradients have transparent areas, represented by a checkerboard pattern. The Transparency option, if turned off, will not allow those transparent areas to be created.

In most cases, leave this option turned on.

### Note

Since gradients are gradual blends of color, they do not look very good in low-resolution files. Pixelation makes the blended areas look distorted.

### Editing Gradients

You can easily change a preset gradient’s appearance or create and save your own gradient presets. To edit a gradient, click on whatever gradient appears on the options bar (not in the Gradient Picker). This causes the Gradient Editor to appear. Figure 6-24. Also, the Eyedropper Tool is activated automatically and is ready to use.

Figure 6-23. The effect of the Reverse option is obvious when applied to a simple two-color gradient. A—the original gradient. B—the gradient after using the Reverse option.

Figure 6-24. In the Gradient Editor, color stops are used to color the gradient and opacity stops are used to create transparent areas.

You can choose any preset gradient in the Gradient Editor, just like you can in the Gradient Picker. The Gradient Editor menu and the Gradient Picker menu are almost identical. After you click on the gradient you want to edit, click the New button to create a copy that is ready for you to adjust.

### Adjusting Color Stops

The Gradient Editor has color stops that appear along the bottom of the sample gradient box. These color stops each represent one color in the gradient and indicate where the color shifts begin and end within the gradient. The colors in the gradient blend from one color stop to the next. Each color stop can be dragged to a different location on the sample gradient box to change the appearance of the gradient. Color stops can be deleted by dragging them downward. A color stop can be added by clicking right beneath the sample gradient box. The color of a color stop can be changed by double-clicking on it. This causes the color picker to appear, from which the new color can be selected. Remember that the Eyedropper Tool is automatically activated when you open the Gradient Editor, so you can easily choose a color from an image file, if desired.

When a color stop is clicked, two tiny diamond-shaped handles appear on either side of it. These diamonds show the midpoint between two colors. You can adjust the location of these midpoints by dragging them.

### Solid and Noise Gradient Types

In the Gradient Editor, you can also choose between two gradient types from the Gradient Type drop-down list. The Solid option creates a gradient with gradual blends of color. The Smoothness setting lets you fine-tune how one color blends into another.

Selecting the Noise option creates gradients that blend colors randomly, making the gradient look choppy. See Figure 6-25. A noise-type gradient does not use color stops to determine the colors used in the gradient. Instead, the colors that will be used in the gradient are determined by first selecting a color mode from the Color Model drop-down list. Once you have selected a color model, a series of sliders appear under the Color Model drop-down list. Adjust these sliders to achieve the desired colors and note the changes in the sample gradient box.

### Note

The HSB (hue, saturation, brightness) color model is especially good for creating monochromatic gradients. The LAB (luminosity, red-green, yellow-blue) color model is best for creating pastel gradients. The RGB (red, green, blue) color model is good for multicolor gradients.

Figure 6-25. This radial gradient was created using the Noise gradient type.
The Paint Bucket Tool

The Paint Bucket Tool is found in the Tools panel behind the Gradient Tool. The Paint Bucket Tool provides a quick way to paint—it dumps the foreground color into either a selected area or an entire layer.

On the Paint Bucket Tool’s options bar, Figure 6-26, you can choose to dump a pattern into an area instead of the foreground color. The Pattern Picker appears when you choose this option.

Just like the Brush Tool, the Paint Bucket Tool has a Mode setting that controls how the paint blends with the colors underneath it. The Opacity setting controls how transparent the paint is.

Because the Paint Bucket Tool is used to fill an area that already contains other colors, it has a Tolerance setting that controls how sensitive the Paint Bucket Tool is when spreading its color on other colored pixels. If the Tolerance is set low, when a pixel is clicked with the Paint Bucket Tool, only similar-colored pixels are filled with the new color. This effect can be seen when dumping white on a gradient, Figure 6-27. To quickly fill a selected area, regardless of the color of the pixels in it, set the Tolerance setting to its maximum: 255.

The Anti-alias option is useful if the filled area contains diagonal lines or curves. Activating this option smooths the edges of the filled area, which would normally be jagged.

Pixels that are touching or bordering each other are called contiguous. When the Contiguous option is turned on, the Paint Bucket Tool dumps color onto similarly colored pixels only if they are touching each other. When the Contiguous option is turned off, similar colors throughout the image are selected.

Activating the All Layers option allows you to simultaneously fill similarly colored pixels on different layers in the image. If this option is not active, you must select each layer individually to fill the desired pixels on those layers. It should be noted that when the All Layers option is active, paint is applied only to the selected layer. If the currently selected layer is at the top of the layer list, then when the paint is applied by the Paint Bucket Tool, it hides similarly colored pixels on other layers. However, if the currently selected layer is lower in the layer stack, the similarly colored pixels on layers above the selected layer will hide the paint applied by the Paint Bucket Tool. For this reason, you may want to create and select a new layer at the top of the layer stack before using the Paint Bucket Tool with the All Layers option active.

The Fill Command

Choosing Edit > Fill... is very similar to using the Paint Bucket Tool. In fact, using the Magic Wand Tool to select an area and then using the Fill command to fill it provides identical results to using the Paint Bucket Tool.

To use the Fill command, begin by making the desired selection. If you do not make a selection, the Fill command will fill the entire layer. Next, choose Edit > Fill... The Fill dialog box opens, letting you choose from several color options, a pattern, or history. Choosing the history option restores the area you selected to the way it looked when you first opened the image. If you are working on a new image rather than a previously saved image, selecting the History option will erase any content in the selected area.

In the Blending section of the Fill dialog box, you will find the Mode and Opacity settings. The Mode setting determines how the fill is blended with the existing image. The Opacity setting determines how visible the fill is. The Preserve Transparency option prevents the Fill command from filling the transparent portions of the selected area.

This option should be active if you are working with an image that has transparent areas and you do not want those areas to be filled.
The Layer > New Fill Layer submenu contains three commands that let you create a new layer that is filled with a color, a pattern, or a gradient.

The Smudge Tool

Imagine using real paints to create a painting. Before letting the paint dry, you smear it with your finger. That is the effect that the Smudge Tool creates. You probably will not use this tool very often. This tool can be used to streak the edges of an object, making it look like it is moving very fast.

The Smudge Tool is found behind the Blur Tool in the Tools panel. The controls found in the Smudge Tool’s options bar are similar to those found in the options bar of other painting tools. The available options include a Brush Preset Picker, Mode settings, and a Strength setting, which controls how “hard” the finger smears the paint. See Figure 6-28.

When the Sample All Layers option is checked, all pixels under the cursor are smudged, no matter what layer they are on. The Finger Painting option, when turned on, adds some of the foreground color to each smudging stroke, creating a slightly messier look.

The Eyedropper Tool

The Eyedropper Tool is grouped with the Ruler Tool, Color Sampler Tool, and Note Tool in the Tools panel. The Measure Tool and Color Sampler Tool are discussed in Chapter 10, Advanced Color-Correction Techniques. The Note Tool is covered in Chapter 12, File Management and Automated Tasks.

The Eyedropper Tool is used to sample, or choose, a foreground color. With only two options in its options bar, this is one of Photoshop’s simplest tools to use. The first setting that is adjustable for the Eyedropper Tool is the Sample Size drop-down list. From this drop-down list, you can select Point Sample, which will sample the color of the single pixel directly under the cursor. You can also choose 3 by 3 Average, which looks at the nine pixels surrounding the cursor, averages their colors, and assigns the resulting color to become the new foreground color. The remaining options work the same way as the 3 by 3 Average setting, but calculate the average color of larger areas, up to 101 x 101 pixels.

It is highly recommended that if you change the Sample Size setting, set it back to Point Sample when you are done with the Eyedropper Tool. Why? Because the setting you choose from the Sample Size drop-down list also affects the performance of the Magic Wand Tool, Paint Bucket Tool, and several other tools you have not yet been introduced to, including the Magic Eraser Tool and the eyedroppers found in the Levels and Curves commands.

Figure 6-28. The Smudge Tool’s options bar is shown here.

The Canvas

A painter paints on a canvas. In Photoshop, the canvas is the entire area of an image. You have already learned about the image size setting in Chapter 2, Resolution. But what happens when you try to combine images that are different sizes? Imagine you want to create text that is similar in color to the purple flowers shown in Figure 6-29. The following is an explanation of the recommended procedure:

- Choose Window > Arrange > New Window for (filename) to create a second view of your file (or zoom in on your original file).
- Zoom in on the second view until you can see individual pixels.
- Choose the Eyedropper Tool and choose one of the Sample Size options in the options bar.
- Position the tip of the Eyedropper Tool cursor over a pixel with the desired color. Click to set the foreground color.
- Now, you are ready to choose the Type Tool and enter purple text.

The Sample drop-down list usually does not need to be switched from the All Layers option to the Current Layer option. Use the Current Layer option and select the appropriate layer in the Layers panel in situations where layers blend together or a layer you want to sample is hidden from view by another layer.

The Eyedropper Tool appears automatically when using some of Photoshop’s features, such as editing gradients. These automatic versions of the Eyedropper Tool work the same as the tool selected in the Tools panel, but they may be used to sample a color other than the foreground color.

Figure 6-29. It is helpful to see individual pixels when using the Eyedropper Tool to pick a color from an image.
you are working on a Photoshop document that is 4” high and 6” wide. Then, you open an image that is 8” × 10”, with the same resolution. You copy it to your original document by dragging it over with the Move Tool. What happens? The portions of the 8” × 10” image that overlap the 4” × 6” canvas are no longer visible. All of the 8” × 10” image is still there (and can be moved around with the Move Tool), but the 4” × 6” canvas is not large enough to display all of it at one time. You have a couple of choices in this situation. You can use the Image Size dialog box to reduce the size of the 8” × 10” image before dragging it over, or you can enlarge the 4” × 6” document by adjusting the size of its canvas.

The Canvas Size command is most often used to create more usable space in an image by expanding its borders. With this command, you can specify a new size for the canvas and to which side of the image the additional, empty canvas will be added. Unlike the Image Size command, this command does not resize the contents of the image, only the space that the image occupies.

Note
Making an image smaller using the Canvas Size command is the same as cropping the image. It is a little easier to use the Crop Tool to make the canvas size smaller.

The canvas size can be made larger or smaller by choosing Image > Canvas Size… This opens the Canvas Size dialog box, Figure 6-30. The current size of the image is displayed in the top section of the dialog box. Enter the desired size for the canvas in the Width and Height text boxes in the New Size section. Be sure to select the proper units from the drop-down lists next to these text boxes.

The Relative check box provides you with an alternative way to enter the desired increase in canvas size. When this check box is checked, you use the Width and Height text boxes to enter the amount of canvas that you want to add rather than the desired overall size of the canvas.

You also need to tell Photoshop what direction to expand the canvas. This is done by clicking the squares in the Anchor section until the arrows display the desired direction(s) of expansion.

The last thing Photoshop asks for is what color the new canvas extension should be. Select a color from the Canvas extension color drop-down list or click the color box next to select a color in the Color Picker. This option is only available if the image has a Background layer.

You can rotate the canvas clockwise or counterclockwise. You can also flip the canvas horizontally or vertically. The commands for these actions are found under the Image > Rotate Canvas… submenu and should be self-explanatory.

Filters
Filters are special effects that can be applied to a layer. Some filters are similar to layer styles that you have already learned about. But most of them create much more complicated effects, such as transforming an image so it looks like a stained glass window. There are approximately one hundred filters, and one of Photoshop’s menus is devoted entirely to them.

When applying a filter to a layer, your image can change drastically. So, it is a good idea to duplicate a layer before applying a filter to it. Another option is to use the feature called Smart Filters. This technology lets you apply a filter non-destructively to a layer. In other words, even though your layer looks like it has been changed by a filter, the filter effect is kept separate by Photoshop. Smart Filters are discussed further in Chapter 11, Additional Layer Techniques.

The Filter Menu
The Filter menu is used to apply a filter. More than one filter can be used on the same layer. Also, the same filter can be applied to a layer multiple times.

The very first item displayed in the Filter menu is the last filter that was used (in case you want to apply it a second time). If you choose this filter (instead of choosing
the filter from its original category), the same filter settings entered previously will be applied to your image again—you will not have the opportunity to adjust the settings.

The second item listed in the Filter menu is **Convert for Smart Filters**. Smart filters are kept separate from the layers they are applied to and, therefore, can be adjusted repeatedly without affecting the original layer. Smart filters are discussed in Chapter 11, Additional Layer Techniques.

The third section of the Filter menu contains the **Filter Gallery** command, which is really a user-friendly interface that makes it easy to explore and use most of Photoshop's filters. Two setting-intensive filters (**Liquify** and **Vanishing Point**) are also contained in this section. The **Liquify** filter will be explained in this chapter, and the **Vanishing Point** filter will be discussed in Chapter 8, Restoring and Retouching Photos.

The fourth section of the menu lists filters by category. The **Artistic**, **Brush Strokes**, and **Sketch** filter categories imitate traditional art practices. The **Video** category contains a filter that adjusts images for use in video (**NTSC Colors**) and a filter that corrects images captured from video (**De-Interlace**).

All of the other filter categories contain an incredible variety of special effects and image-tweaking power. There are thousands of different textures and patterns that can be created with different combinations of filters. There are many free tutorials on the Internet that will show you how to use filters in creative ways. For beginners, a good way to become acquainted with filters is to try them out, one by one. You will be asked to try out each filter and save your results in the tutorial section of this chapter.

What happens when you select a filter depends on the filter that is selected. If the filter is very basic, like the **Blur** filter, it is applied immediately, without any further user input. Some filters with adjustable settings open a dialog box containing the filter controls. This is usually the case for filters that are relatively simple (such as the **Unsharp Mask** filter) or filters that are relatively complex (such as the **Lighting Effects** filter). All other types of filters open the Filter Gallery when they are selected.

**The Filter Gallery**

When certain types of filters are selected, the **Filter Gallery** appears, Figure 6-31. In order to display the Filter Gallery correctly, the display resolution of your computer must be set to 1024 × 768 or higher.

If you click the small double arrow button to the left of the **OK** button, the **Filter Gallery** displays some of the available filters. All of the filters in the **Artistic** category appear in the Filter Gallery’s filter list, but this is not true for some of the other filter categories. Some filters are too complex or too simple to be displayed in the Filter Gallery. Be aware that the Filter menu is the only place you will see all of the filters.

The filter list in the **Filter Gallery** shows thumbnail examples of what each filter does. When you choose a specific filter, its adjustable settings appear in the section at the right. For example, in Figure 6-31, the colored pencil filter's settings are displayed. This filter is designed to make a digital image look like it was created with colored pencils. You can control how fat the pencil strokes are (**Pencil Width**), how hard the pencils are pressed (**Stroke Pressure**), and whether the paper is black, gray, or white (**Paper Brightness**).

After adjusting the settings as desired, click **OK** to apply the filter. Filters are not automatically created on a new layer, so a safe habit is to always create a duplicate layer before applying a filter, leaving your original image untouched.

Assigning Multiple Filters in the Filter Gallery

If you want to add multiple filters in the **Filter Gallery** at the same time, click the **New effect layer** button instead of the **OK** button. This creates a copy of the currently selected filter and settings at the top of the filter stack. To change a filter into a different type of filter, simply select that filter in the filter stack and click the thumbnail of the desired filter in the filter list to the left. Make the necessary changes to the filter settings and observe the results in the preview window. At this point you can adjust the filter stacking order, click **OK** to accept the filters as they are, or add yet another filter.

The order that the filters appear in the filter stack influences the effect produced by the filter combination. To change the order of filters in the stack, simply click and drag them above or below each other as you learned to do with layers in the **Layers** panel. The filters are applied in order, beginning with the filter at the bottom of the stack and working upward. To remove a filter from the stack, simply select it and click the **Delete effect layer** button. When the combined filter effect is the way you want it, click the **OK** button to apply the filters to the image.

**The Liquify Filter**

The **Liquify** filter is complex enough to be a separate item in the third section of the Filter menu. This filter has several bizarre tools that let you manipulate pixels. The **Liquify** filter is often used for humorous purposes, such as modifying someone’s face, but you can also use this filter to make subtle, precise adjustments to images. This filter includes tools that are used to mask (protect) areas of your image to ensure accuracy.
The Liquify Filter Tools

At the left side of the Liquify dialog box, is a collection of new tools, Figure 6-32. They are briefly described here, in order from top to bottom:

- The Forward Warp Tool is used to grab pixels and push them to another location.
- The Reconstruct Tool changes the image back to its original state. If necessary, use this tool as an “eraser.”
- The Twirl Clockwise Tool twists pixels in a clockwise direction as you press the mouse button (hold down the [Alt] or [Option] key for counterclockwise).
- The Pucker Tool causes an area of pixels to appear to shrink as you press the mouse button. The effect decreases in intensity from the center of the brush out to its edges.
- The Bloat Tool causes an area of pixels to look larger as you press the mouse button. Again, the effect decreases in intensity from the center of the brush outward.
- The Push Left Tool stretches and moves an area to the left, creating a stretched look (hold down the [Alt] or [Option] key to push pixels the opposite direction).

Figure 6-32
The Liquify filter allows you to easily apply a variety of distortions to selected portions of your image while leaving the rest unaffected. A—The original portrait is shown here. B—The nose and lip areas have been manipulated with the Liquify filter’s Bloat Tool. C—The nose, lips, and eyes have been modified with the Pucker Tool.

The Mesh

A mesh is a grid that helps you see how the image was changed with the Liquify Filter tools. You can view the changes you made to your file as a mesh by placing a check mark in the Show Mesh check box in the View Options section of the dialog box. You can hide the actual image by removing the check mark in the Show Image check box. This gives you a better view of the mesh, which is helpful in some situations. The size of the mesh can be adjusted by choosing one of the options in the Mesh Size drop-down list, and you can change the color by selecting a new color from the Mesh Color drop-down list.

You can also save a mesh as a file and load it later, when another image is open in the Liquify dialog box. In other words, you can apply saved Liquify filter tool effects to another image. This is done using the Load Mesh and Save Mesh buttons at the top of the dialog box.

Liquify Tool Options

The Tool Options section of the Liquify dialog box contains adjustable controls for the Liquify filter tools. Certain settings may be grayed out depending on the tool that is selected. You can use the Brush Size slider to change the size of the area affected by each stroke or click of the Liquify filter tool. The Brush Density slider controls how “thick” the brush is (similar to controlling the softness of the edges of a brush), and the Brush Pressure slider controls how intensely the brush effect is applied. The Brush Rate slider is available only for tools that are applied repeatedly when the mouse button is held down. This setting determines the rate at which the tool application is repeated. The Turbulent Jitter slider setting determines the degree of uniformity in the distortions created in the mesh by the Turbulence Tool. The Reconstruct Mode drop-down list contains several options for the way the Reconstruct Tool is applied to the mesh. The Revert option restores the mesh to its original shape and position. The remaining options in the drop-down list restore the mesh, but use different methods to do it.

Reconstruct Options

The options available in the Mode drop-down list from this section of the dialog box are nearly identical to the options in the Reconstruct Mode drop-down list in the
Focal Point and Visual Hierarchy

Usually, one part of a graphic design is dominant. It is the center of interest, the part of the design that the viewer's eye is attracted to the most. Occasionally, a design may use repetitive patterns instead of a single focal point. Then, the entire design attracts the attention of the viewer.

The greater the emphasis, or visual weight, placed on part of a design, the more the viewer will notice it. The most obvious way to give more visual weight to a design element is to make it larger than the other design elements. Here are some other tips for creating more visual weight to a design element:

- Use vivid colors that contrast with the background.
- Add a special effect such as a shadow, highlight, or distortion to the subject.
- When working with text, make the text bolder or use appropriate decorative fonts.
- Rotate design elements so they are not perfectly horizontal or vertical.
- Position other design elements to effectively contrast with the element that is the focal point.

The focal point of the poster in Figure 6-33 is the “Farmer’s Market” text. It carries more visual weight than any other design element on the poster. The text is white, a color that contrasts well with the background. A drop shadow and a black border (stroke) were also added to help the text “jump out” at the reader. Notice that the text is sans serif, creating easily-read headlines.

After the reader's eye jumps to the focal point of the design, elements of the design should be organized in such a way that the reader does not have to search for important information. The designer should assign a visual weight to the next important item in the design. A visual hierarchy is the order in which design elements are presented from the greatest amount of visual weight to the least.

Designers can use color, size, and the position of objects to create a visual hierarchy. For example, lighter and duller colors carry less visual weight than bright, vivid colors. It is also important to not crowd design elements together. Some white space (empty space) is needed to make absorbing the information easy.

Imagine driving along a freeway and seeing the billboard shown in Figure 6-34. Most people would agree that the focal point of this design is the large ostrich—it is a huge, unusual image. The “Ostrichville” title text is the next item in the visual hierarchy. Its size, color, and special effects give it almost as much visual weight as the ostrich.
Summary

When you have a few extra minutes, take a close look at all of the brushes in the Brushes panel. You will need to choose a brush shape and size when using many of Photoshop’s tools. Knowing what brushes are available can save you time—by choosing just the right tool shape for a quick, easy edit. Filters can adjust images in amazing ways. Some filters can help clean up problem photographs. Others can be used in combination to create interesting textures and patterns from scratch. Photoshop users have discovered (and continue to discover) a vast amount of filter techniques. These techniques are shared on the Internet as Photoshop tutorials or found in more advanced books or Photography, Graphic Design, and Digital Imaging magazines.

Note

The files needed to complete the tutorials in this book can be downloaded from the Learning Photoshop CS4 Student Companion Web Site. Refer to the “Using the Companion Web Site” section of the book’s Introduction for more information.

You will try a couple of painting methods in these tutorials. You will be asked to try out each filter and save your results into a folder. You will also use painting tools and filters to make further modifications to projects you have already begun in previous chapters.

Tutorial 6-1: Exploring Filters and Styles

In this tutorial, you will be asked to save almost 100 small files. In the process, you will discover the power and flexibility of Photoshop’s filters and styles. The effects produced by these tools are so widely varied that the only way to familiarize yourself with them is through hands-on experience.

Part 1: Filters

Photoshop’s filters can be used to add a variety of effects to an image. The effects range from very subtle color changes to absurd distortions of the image.

1. Create a new folder named Filters and save each file in this new folder.
2. Open the file named Buster.jpg.
3. If the grid is showing, turn it off by choosing View > Show > Grid.
5. Choose Filter > Artistic > Colored Pencil.…
6. Experiment with the filter settings. Once you have the filter settings the way you want them, click OK.
   Choose settings that do not “destroy” the original photo. Your settings should make Buster look like he was drawn with colored pencils.
7. Choose File > Save As….
8. Name this file Colored Pencil.jpg, make sure it will be saved in the Filters folder you created, and click Save.
9. In the JPEG Options dialog box, click OK to accept the default settings.
10. Choose Edit > Step Backward to remove the colored pencil filter.
11. Choose Filter > Artistic > Cutout.
12. Experiment with the filter settings and click OK.
13. Choose File > Save As... and name the file Cutout.jpg.
14. In the JPEG Options dialog box, click OK to accept the default settings.
15. Try out the rest of the filters in the Artistic category in the same way. As you experiment with the filters, keep the following things in mind:
   - Save each file as you did in steps 7–9, using the filter name as the name of the file.
   - Change the foreground color to get different results with the Neon Glow filter.
16. When you have tried all of the filters in the Artistic category, choose Filter > Blur > Blur More.
   Skip the first two filters in the Blur category.
17. Experiment with each of the blur filters and save each result.
18. Try out each filter in all of the remaining categories except for the following:
   - Skip the Video category.
   - Skip the Sharpen category. You will learn more about the sharpen filters in Chapter 8, Restoring and Retouching Photos.
   - Keep in mind that the Stained Glass filter and most of the filters in the Sketch category make use of the foreground color (so experiment with different foreground colors).
   - The Neon Glow, Clouds, and Fibers filters use both the foreground and background colors.
   After experimenting with the filters, you should have almost 100 files saved in your Filters folder. There are several more files you will create and save to this folder.
19. Close all files on your screen and open the original Buster.jpg file again.
20. Use the Magic Wand Tool to select the sky behind Buster.
22. Select Burlap from the Texture drop-down list. Set the Scaling slider to 115% and the Relief slider to 5. Click OK.
   The filter is applied to the selected area.
23. Choose File > Save As... Name the file Buster with burlap.jpg and save it in the Filters folder.
25. Choose Filter > Artistic > Cutout.
26. Experiment with the filter settings and click OK.
27. Choose File > Save As... and name the file Cutout.jpg.
28. In the JPEG Options dialog box, click OK to accept the default settings.
29. Try out the rest of the filters in the Artistic category in the same way. As you experiment with the filters, keep the following things in mind:
   - Save each file as you did in steps 7–9, using the filter name as the name of the file.
   - Change the foreground color to get different results with the Neon Glow filter.
30. When you have tried all of the filters in the Artistic category, choose Filter > Blur > Blur More.
   Skip the first two filters in the Blur category.
31. Experiment with each of the blur filters and save each result.
32. Try out each filter in all of the remaining categories except for the following:
   - Skip the Video category.
   - Skip the Sharpen category. You will learn more about the sharpen filters in Chapter 8, Restoring and Retouching Photos.
   - Keep in mind that the Stained Glass filter and most of the filters in the Sketch category make use of the foreground color (so experiment with different foreground colors).
   - The Neon Glow, Clouds, and Fibers filters use both the foreground and background colors.
   After experimenting with the filters, you should have almost 100 files saved in your Filters folder. There are several more files you will create and save to this folder.
33. Close all files on your screen and open the original Buster.jpg file again.
34. Use the Magic Wand Tool to select the sky behind Buster.
35. Choose Filter > Texture > Texturizer.
36. Select Burlap from the Texture drop-down list. Set the Scaling slider to 115% and the Relief slider to 5. Click OK.
   The filter is applied to the selected area.
37. Choose File > Save As... Name the file Buster with burlap.jpg and save it in the Filters folder.

Part 2: Styles
Some of Photoshop's styles work very well with image files. Some of these styles are similar to some of the filters you have used.
1. Open the original Buster.jpg file again.
2. Click the Styles panel tab.
3. Double-click the Adjustments panel tab to collapse the panel tab group.
4. Position the cursor over the bottom edge of the Styles panel. When the cursor changes to double arrows, click and drag to increase the length of the panel.
5. Open the Styles panel menu and choose Photographic Effects.
6. Click OK in the dialog box that appears to replace the styles in the panel.
7. Open the Styles panel menu again and choose Image Effects.
8. In the dialog box that appears, click the Append button to add the Image Effects styles to the panel without deleting the Photographic Effects styles.
9. Open the Styles panel menu and choose Small List.
   This changes the style list from a thumbnail display to a list of names with tiny thumbnails.
10. Click on one of the styles. Nothing happens because the layer is locked.
11. Unlock the layer in the Layers panel by double-clicking the Background layer in the Layers panel.
   In the New Layer dialog box, click OK to accept the default name for the layer.
12. Click each of the effects you have loaded into the Styles panel and save each result into the Filters folder. Use the style name as the file name.
13. When you have saved an image adjusted with each of the styles, open the Styles panel menu and choose Reset Styles. Click OK in the box that appears.
14. Choose Window > Workspace > Essentials (Default) to reset the workspace to its default settings.
Tutorial 6-2: Coloring a Photo with the Brush Tool

In this tutorial, you will use the Brush Tool with the Hue blending mode to change the color of a selected part of an image. This technique is useful for calling attention to one element within an image.

1. Open the peppers.jpg file.
2. Choose Layer > Duplicate Layer... Name the new layer Paint. You will paint this layer and leave the original layer untouched, in case you need to start over.
3. Select the bottom center pepper, but not its stem. To select the pepper, zoom in far enough so you can use the selection tools easily. Use the Magnetic Lasso Tool to start. Then, switch to the Lasso Tool with the Feather option set to 0. Use the Add to selection and Subtract from selection buttons to fine-tune your selection border.
4. Click the Brush Tool in the Tools panel.
5. Enter the following settings in the options bar:
   - In the Brush Preset Picker, set the Master Diameter to 250 pixels and Hardness to 100%.
   - Select Hue in the Mode drop-down list.
   - Set the Opacity slider to 100%.
6. Click the Paint Bucket Tool in the Tools panel and click inside the selected area to dump yellow on the background layer.
7. Without releasing the mouse button, paint the pepper. If you release the mouse button before you finish painting, the brush strokes will overlap and appear too dark.
8. Choose File > Save As... and name the file 06peppers.psd.
9. Close 06peppers.psd. You will make other changes to this file later.

Tutorial 6-3: The Paint Bucket and Gradient Tools

In this tutorial, you will use the Paint Bucket Tool to add a solid fill of the foreground color to a selected area. You will then add a gradient from foreground color to transparency to create a glow effect around the filled area.

1. Open the 04leafy.psd file that you created in a previous chapter.
2. Collapse the Adjustments panel tab group by double-clicking the Adjustments panel tab.
3. In the Layers panel, click the Background layer to make it active.
4. Click the Elliptical Marquee Tool.
5. Create a selection border around the “sunshine” shape, as shown. Remember to hold [Shift] to create a circle instead of an ellipse and [Alt] to create the circle from the center outward.
6. Click on the Swatches panel and click on the yellow-colored box in the top row. Notice that the foreground color is now yellow.
7. Click the Paint Bucket Tool in the Tools panel.
8. Click inside the selected area to dump yellow on the background layer.
9. In the Layers panel, click on the layer at the very top of the stack to make it active.
10. Click the Create a new layer button in the Layers panel or choose Layer > New > Layer....
11. Name the new layer gradient.
12. Select the Ellipse Marquee Tool in the Tools panel.
13. Click and release anywhere in the image to clear the previous selection.
14. Select the Gradient Tool in the Tools panel.
15. In the options bar, click the small down-arrow to open the Gradient Picker.
16. In the Gradient Picker, pick the small arrow button to open the Gradient Picker menu. Select Reset Gradients... from the menu, and click OK in the dialog box that appears. If a second dialog box appears asking if you want to save current gradients before replacing them, choose No.
17. Choose the second gradient, which is always the foreground color (in this case, yellow) and transparency.
18. In the options bar, click the Radial Gradient button.
19. Starting in the center of the leafy design, drag a line as shown to add a sunglow effect.
20. Choose File > Save As... and name this file 06leafy.psd. Close the file when you are done.
8. Add an inner bevel style to this layer by repeating steps 4 and 5.
   Your design should look like the example on the right.
9. On the Layers panel, click the Background layer.
10. Reset the foreground and background colors to black and white.
11. Click the Paint Bucket Tool in the Tools panel.
12. Click any white area of the image to fill the Background layer with black.
13. Make the top layer active in the Layers panel.
   You are about to add text, and the new text layer will be created above the active layer.
14. Add the text shown in the example on the right. Choose your own font and layer styles.
15. Choose Layer > Flatten Image.
16. Choose File > Save As... and name the file 06CDback.psd.
17. If you are going to continue on to the next tutorial, leave the file open. If you are not going to continue on to the next tutorial, close the image.
   You will sample colors from this image as you create the back insert for the CD jewel case in the next tutorial.

Tutorial 6-5: The Eyedropper and Gradient Tools

In this tutorial, you will define a gradient and apply it to a CD insert design. You will use the Eyedropper Tool to select colors from one image to use in creating a gradient in another image. This technique is useful for keeping color schemes consistent, visually tying together multiple documents.

1. Open the 06CDfront.psd file, if it is not already open.
2. Choose File > New... and enter the settings shown. Name the image 06CDback.
3. Click the Arrange Documents button and choose Float All in Windows from the menu. Move the new file window so you can see the 06CDfront.psd window behind it.
4. Click on the Eyedropper Tool in the Tools panel.
5. Click on a non-beveled portion on the red ring.
The Eyedropper Tool changes the foreground color to red.
6. Choose View > Rulers.
7. Click the Rectangular Marquee Tool.
8. In the options bar, make sure that the Feather option is set to 0 px.
9. In the options bar, choose the Fixed Size option from the Style drop-down list.
10. Enter .25 in in the Width box and 4.75 in in the Height box.
11. Click near the left side of your file to create the rectangular selection.
12. Use the arrow keys if necessary to place the selection so it touches the left edge and top and bottom of your file.
13. Use the Paint Bucket Tool to fill the rectangular selection with red.
15. Choose **Edit > Paste**.
Another red rectangle is pasted exactly on top of the first rectangle. Notice that a new layer was created automatically.

16. Click the **Move Tool** in the **Tools** panel, hold down **[Shift]**, and use the arrow keys to move the second rectangle exactly into position. Holding **[Shift]** while you move the selection helps speed up the process. However, you will need to release **[Shift]** and use just the arrow keys to position the selection precisely at the other edge of the image.

17. Choose **Layer > Flatten Image** to add the red rectangles to the **Background** layer.

18. Reposition the **06CDback** image window as needed so that the **06CDfront.psd** window is visible behind it.

19. Click the **Gradient Tool**, located behind the **Paint Bucket Tool** in the **Tools** panel.

20. In the options bar, click the down arrow to display the **Gradient Picker**.

21. Click the arrow that opens the **Gradient Picker** menu and choose **Color Harmonies I**.

22. In the dialog box that appears, click **OK** to replace the gradients in the picker. If another dialog box asks you if you want to save changes to the current gradients, click **No**.

23. Click the first gradient listed in the picker.

24. Click the gradient in the options bar to display the **Gradient Editor**.
When the **Gradient Editor** opens, the **Eyedropper Tool** is automatically selected.

25. Click the color stop at the far left end of the color slider. This color stop is light blue by default.

26. Click a portion of the black background in the **06CDfront.psd** image to choose the black color.

27. Click the next color stop.

28. Click the blue area of the **06CDfront.psd** image with the **Eyedropper Tool**.

29. Click the third color stop and select a red part of the design with the **Eyedropper Tool**.

30. Click the fourth color stop and make it blue.

31. Click the fifth color stop and make it red.

32. Click the last color stop and make it black.
33. Add a color stop by clicking between the fifth and last color stops. Change its color to blue.

34. Drag the color stops until they are evenly spaced. Watch the value displayed in the Location text box as you drag each color stop. The Location values that will give you evenly spaced color stops are shown.

35. Click OK to accept the changes and close the Gradient Editor.

36. Reposition the 06CDback window so that it is not blocked by any other windows or panels.

37. Use the Magic Wand Tool to select the white area between the red rectangles in the 06CDback image.

38. Click the Gradient Tool.

39. In the options bar, click the Radial Gradient button, select Normal in the Mode dropdown list, and set the Opacity slider to 90%.

40. Drag a line in the selected area, as shown.

41. Choose Select > Deselect.

42. Choose View > Rulers to hide the rulers.

43. Click the Rectangular Marquee Tool. In the options bar, set the Style drop-down list back to normal.

44. Close the 06CDfront.psd image. Then, save and close the 06CDback.psd image. You will add more to it later.

Tutorial 6-6: Using the Clouds Filter (and Creating a Panorama)

A panorama is a large image made up of several smaller ones. Even though you have not been introduced to creating panoramas in Photoshop, you will find it is easy to do. In this tutorial, you will create a panoramic view of scenery and then fix the sky with the Clouds filter.

1. Click the Launch Bridge button on the Application bar.

   This opens Bridge, Photoshop’s built-in file browsing application. See Chapter 12, File Management and Automated Tasks, for more information about Bridge.

2. If a dialog box appears asking if you want Bridge to automatically launch at login, click No.

3. Find the folder named panorama and open it.
4. Drag the Thumbnail size slider to the right until the nine image thumbnails fill the window.

Can you tell that the photographer stood in one spot while capturing all of these images? Since the images overlap somewhat, and were taken from a shared vantage point, Photoshop’s Photomerge feature will automatically assemble all of these photos into one panoramic photo.

5. Select all of the images by dragging a window around them. You may need to make the thumbnail size smaller again before doing this.

6. Choose Tools > Photoshop > Photomerge....

The Photomerge command can also be launched directly from within Photoshop by choosing File > Automate > Photomerge.... The image files would then need to be located and loaded by clicking the Browse button in the Photomerge dialog box.

7. In the Photomerge dialog box, the images are listed and the Auto radio button is enabled. Leave these settings as they are.

8. Click the OK button.

It may take more than a minute for Photoshop to open, analyze, overlap, and blend each photo into a single image.

9. Your final image should look like the scene to the right.

The checkerboard pattern means no color is there—only transparent, empty space.


12. Name the file 06hillside.psd.

13. Close the Bridge program.


15. With the Crop Tool selected, drag a box like the one shown at the right.

16. On the right side of the crop box you just created, grab the middle handle on the right edge and drag it to the right edge of the image.

17. Grab the middle bottom handle and adjust the bottom of the crop box until it is flush with the bottom of the actual image on the right side. Grab the top middle handle and drag it to the top edge of the image area. Continue adjusting the crop box until it looks like the example to the right.

The very bottom portion of the image area should be the only part that does not have the crop box around it.
18. Click the Commit button in the options bar or press [Enter].
   The word “crop” means “to remove an unwanted portion.” Everything that was inside the crop box stayed, and the rest of the file was removed.
19. Click the Magic Wand Tool.
20. In the options bar, set the Tolerance to 20. Make sure the Contiguous check box is checked.
   The Contiguous option prevents sky-colored pixels from being selected in the mountains or on the road.
21. Click anywhere on the sky.
22. Click the Add to Selection button.
23. Continue clicking until all of the sky and the transparent (checkered pattern) areas are selected.
24. In the Tools panel, click the Set foreground color button.
25. In the Color Picker, choose a very light blue color by adjusting the color slider and then picking a light blue color from the color field.
26. Click OK.
27. The background color box should already be white. If not, you can choose white by clicking on the background button in the Tools panel and then clicking the extreme upper-left corner of the color field in the Color Picker dialog box.
28. Choose Filter > Render > Clouds.
   This command blends the blue and white colors into a cloud-like pattern.
29. Choose Select > Deselect.
   The selection border disappears.
30. Make sure the layer containing the panoramic view is selected in the Layers panel, and then choose Layer > New > Background From Layer.
31. Save and close the image. You will add more to this file later.

Tutorial 6-7: Turn a Photo into a Painting

In this tutorial, you will use the Find Edges filter to essentially trace an image, and then use the Brush Tool to apply paint to the image. You can use this technique to quickly create a “hand-painted” design from a photo.
1. Open the Buster.jpg file.
2. Choose Layer > Duplicate Layer…. Accept the default layer name in the Duplicate Layer dialog box.
   Desaturate means to remove the color.
5. Choose Layer > New > Layer….
6. Name the new layer Paint and click OK.
7. In the Layers panel, set the opacity of this new layer to 45%.
8. Use the Brush Tool to paint new colors over Buster.
   Experiment with different brush styles and sizes.
   Because you will be painting on a separate layer, you can use the Eraser Tool to erase paint that goes outside of the lines. You can also use the Edit > Undo and Edit > Step Backward commands.
9. When you think you have the image the way you want it, increase the opacity of the Paint layer to 100%.
10. Since the image may look different once the opacity of the layer is increased, make any needed adjustments to the image. You may want to add a layer directly below the Paint layer and fill it to make the painted areas stand out.
11. Choose File > Save As... and name the file 06Buster.psd.

### Key Terms

- brush marks
- gradient steps
- canvas
- jitter
- tiled color stops
- mesh
- visual hierarchy
- contiguous
- sample
- visual weight

### Review Questions

*Answer the following questions on a separate sheet of paper.*

1. How do you create a perfectly straight line with the Brush Tool?
2. List three different ways you can change the brush size.
3. If you set the Opacity of the Brush Tool under 100%, how will the paint appear?
4. When using an Opacity setting of less than 100%, how can you avoid darkening areas where the paint overlaps itself?
5. What setting in the Brush Preset Picker controls how soft the edges of a brush are?
6. In the Brush Preset Picker and the Brushes panel, how do you restore the default brushes (the brushes that appear when Photoshop is first installed)?
7. Which blending mode only paints in transparent areas?
8. Which blending mode changes an object's color, but preserves shadows and highlights?
9. Briefly describe how the Brushes panel is different than the Brush Preset Picker.
10. What does jitter mean?
11. How do you reset all of the settings in the Brushes panel?
12. Describe how to create a custom brush tip.
13. What is the main difference between the Pencil Tool and the Brush Tool?
14. When using the Pattern Stamp Tool, how can you create your own pattern?
15. When the default gradients are loaded in the Gradient Picker, what will the very first gradient look like?
16. What difference results from creating a gradient by dragging a long line and creating a gradient by dragging a short line?
17. Why should you avoid creating gradients in files that have a low resolution?
18. How do you open the Gradient Editor?
19. What two kinds of fill can you add with the Paint Bucket Tool?
20. What does the Tolerance setting in the Paint Bucket Tool's options bar do?
21. What is the difference between the Point Sample option and the 3 by 3 Average option for the Eyedropper Tool?
22. What other tools are affected when you change the Eyedropper Tool's Sample Size setting?
23. What is Photoshop's Canvas Size command used for?
24. What tool can you use to make a file's canvas size smaller?
25. What is the purpose of the mesh feature in the Liquify filter?