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Certification Prep Series
by D. Michael Ploor
Certification Prep Series consists of individual guides that provide practice in the 
basic skills needed to be successful using the corresponding software. No previous 
software experience is required. Although the guides focus on learning skills, not 
test taking, users that complete the practice will be prepared to take the official 
software certification exam and exhibit workplace readiness. Step-by-step instructions 
demonstrate actual software commands and features, building from basic to advanced. 
Content is divided into small units for better learning and usage. There is no need to 
purchase additional materials as all lesson content is created using the software.

•	 Provides an affordable way to prepare for industry certification versus other methods.
•	 Integrates easily into existing classroom activities.
•	 Focuses on hands-on experience to develop skills.

Microsoft Office Products
•	 Microsoft Word 2016

•	 Microsoft Excel 2016

•	 Microsoft PowerPoint 2016

•	 Microsoft Outlook 2016

•	 Microsoft Access 2016

•	 Microsoft Word 2013

•	 Microsoft Excel 2013

•	 Microsoft PowerPoint 2013

•	 Microsoft Outlook 2013

•	 Microsoft Access 2013

Adobe Products
•	 Adobe Photoshop Creative Cloud

•	 Adobe Dreamweaver Creative Cloud

•	 Adobe Animate Creative Cloud

•	 Adobe Illustrator Creative Cloud

•	 Adobe InDesign Creative Cloud

•	 Adobe Photoshop CS6

•	 Adobe Dreamweaver CS6

•	 Adobe Flash CS6

•	 Adobe Illustrator CS6

•	 Adobe InDesign CS6

•	 Adobe Photoshop CS5

•	 Adobe Dreamweaver CS5

•	 Adobe Flash CS5

Microsoft Office 2010 is also available.

Start on Monday.
Test on Friday.
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4 CORE Adobe Animate Creative Cloud

Introduction
The Common Occupational Readiness Essentials (CORE) series of certifi cation 
preparation guides focuses on mastering the essential basic skills needed as 
a workplace-ready user of the software. The goal of each CORE certifi cation 
preparation guide is to provide practice in each essential basic skill required by 
employers who use the software. To prove workplace readiness, you will also be 
prepared to take the offi cial certifi cation exam for the software.

CORE Adobe Animate CC will help prepare you to take the Adobe Certifi ed 
Associate (ACA) Adobe Animate CC certifi cation exam. It provides step-by-step 
instruction for the features and commands covered on the certifi cation exam. 
The focus of the lessons is to practice using the actual commands and features 
instead of creating a complete end product. Most lesson content is created using 
the software, and minimal downloading of fi les is required. Furthermore, each 
certifi cation preparation guide is broken down into small learning units to enable 
better comprehension and application of the software. Where required, answers are 
provided at the back of the certifi cation preparation guide.

Certifi cation as an Adobe Certifi ed Associate demonstrates an aptitude with Adobe 
software. ACA certifi cation is offered for Adobe Dreamweaver, Adobe Animate, 
Adobe Photoshop, Adobe Premier, Adobe Illustrator, and Adobe InDesign. 
Certifi cation exams are provided by Certiport, Inc., through various testing facilities. 
Visit www.certiport.com for more information on registering for certifi cation exams.

About the Author
D. Michael Ploor is the author of the CORE series of certifi cation preparation guides. 
Mr. Ploor’s students have achieved exceptional results with the CORE certifi cation 
preparation guides. His students collectively pass more than 500 industry certifi cation 
exams each year without the need for other preparation materials. Mr. Ploor has 
demonstrated the strength of integrating the CORE guides in a diverse mix of courses.

Mr. Ploor is also the author of three textbooks on the subject of video game 
design: Introduction to Video Game Design, Video Game Design Foundations, and 
Video Game Design Composition. He is a National Board Certifi ed Teacher in Career 
and Technical Education and holds an MBA degree from the University of South 
Florida. He maintains professional teaching credentials in Business Education and 
Education Media Specialist.

Mr. Ploor is at the forefront of innovative teaching and curriculum. He developed 
STEM curriculum while serving as the lead teacher in the Career Academy of 
Computer Game Design at Middleton Magnet STEM High School. Mr. Ploor 
has applied his skills as a STEM Curriculum Integration Specialist in designing 
innovative curriculum and by collaborating to construct the state standards for 
video game design in several states. He has also been instrumental in authoring 
competitive events for Career and Technical Student Organizations such as the 
Future Business Leaders of America (FBLA) and Phi Beta Lambda (PBL).

In addition to publishing textbooks and lessons, Mr. Ploor provides professional 
development as a frequent presenter at regional and national conferences to 
promote CTE education and video game design curriculum for the high school and 
middle school levels.
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Lesson 4
Images and Text

Objectives
Students will set the stage dimensions. Students will import an asset into the 
library. Students will trace a raster image to create a vector image. Students will 
replace color on an object. Students will obtain data from the Info panel. Students 
will create an image mask. Students will describe how to add text to an Animate 
document. Students will adjust color effects on an object. Students will publish an 
Animate document in other formats.

How to Begin
 1. Before beginning this lesson, download the needed fi les from the student 

companion website located at www.g-wlearning.com, and unzip them into your 
working folder.

 2. Launch Animate.

 3. Applying what you have learned, create a new ActionScript 3.0 document.

 4. Click File>Save As… on the Application bar. A standard save-type dialog box is 
displayed. Save the fi le as LastName_Balloon in your working folder.

Setting Stage Dimensions
The stage has a default size, but the size often must be changed to match the 
requirements of the project. The stage dimensions are changed using the Properties 

Panel.

 5. Locate the Size: options in the Properties 
section of the Properties panel.

 6. Click the value next to W:, and enter 600. This 
changes the width of the stage from the default 
550 pixels to 600 pixels. Notice the stage in the 
document window increases in size to match.

 7. Click the Advanced Settings… button in the 
Properties section to display the Document 

Settings dialog box, as shown in Figure 4-1. 
The size of the stage can be changed directly in 
the Document Settings dialog box.

 8. Click the value next to H:, and enter 600. This is 
the number of pixels in height for the document 
and stage. Notice to the right of the H: value is 
the label px. The px means pixels, so the values 
for width and height are measured in pixels. 
Click the OK button to the change the size of 
the document and stage.

TIP
The Document 

Settings dialog 
box can also be 
displayed by 
clicking Modify> 
Document… on the 
Application bar.

Click to change
the value

Enter a new
value

Goodheart-Willcox Publisher

Figure 4-1. 

The stage size is set by changing the document 
dimensions.
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Importing to the Library
Assets are the elements within an animation, such as objects, sounds, background, 
and characters. Assets can be added to the Library panel using the Import 
command. This creates a library for the project, which is a central storage location 
so assets can be quickly located and added to the animation.

 9. Click File>Import>Import to Library… on the Application bar. A standard open-
type dialog box is displayed. It may take a few seconds for Animate to prepare 
to import before the dialog box appears.

 10. Navigate to your working folder, select the Hot 
Air Balloon image fi le, and click the Open button. 
The asset is added to the library.

 11. Click the Library panel to display its contents, as 
shown in Figure 4-2.

 12. Click the Hot Air Balloon.jpg fi le name in the 
lower part of the panel to preview the image.

 13. With the Hot Air Balloon image selected in the 
library, click the panel menu button in the top-
right corner of the panel, and click Properties… 
in the drop-down menu. The Bitmap Properties 
dialog box is displayed, as shown in Figure 4-3. 
Notice the information at the bottom of 
the dialog box. The current compression 
method has reduced the fi le size to 10% of the 
uncompressed size.

 14. Click the Compression: drop-down arrow, and 
click Lossless (PNG/GIF) in the drop-down list. 
This will change the compression method to 
lossless compression.

Goodheart-Willcox Publisher

Click to display
the panel

Panel
menu button

Click to select the asset
and preview the image

Preview

Figure 4-2. 

Imported assets are displayed in the Library panel.

Goodheart-Willcox Publisher

Click to test
the setting

Select a
compression
method

Click to allow smoothing

Figure 4-3. 

Changing the properties of a raster image in the library.
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 15. Click the Test button. Notice this compression method only reduces the fi le size 
to 26% of the uncompressed size.

 16. Check the Allow smoothing check box, and click the OK button to update the 
asset.

 17. Drag the Hot Air Balloon image fi le from the Library panel, and drop it onto the 
stage. The asset is inserted into the current frame.

 18. Click the zoom setting drop-down arrow at the upper-right corner of 
the document window, and click Show All in the drop-down menu. The 
magnifi cation of the document is changed so everything fi ts within the 
document window.

 19. With the asset selected, display the Properties panel.

 20. Click the X: coordinate in the panel to make it editable, and enter 75.

 21. Click the Y: coordinate in the panel, and enter 0.

 22. Click the link icon to the left of the W: dimension. This locks the aspect ratio 
so as the width is changed, the height is proportionally changed or vice versa. 
When locked, the icon is an unbroken chain.

 23. Click the H: dimension in the panel, and enter 600. This sets the height of the 
image to match the height of the stage. The image now fi ts entirely within the 
stage and is centered.

 24. Double-click on the layer name (Layer 1) in the Timeline panel. The name is 
made editable. Change the name to Balloon. Press the [Enter] key to set the name.

Tracing a Raster Image
Vector images, not raster images, are the best to use in an Animate animation. 
However, the balloon image is a raster image. It needs to be converted to a vector 
image. Some image quality will be lost in the conversion.

 25. Click the New Layer button in the Timeline panel.

 26. Right-click on the new layer ([Command]-click on a Mac), and click Properties in 
the shortcut menu to display the Layer Properties dialog box.

 27. Click in the Name: text box, and enter Vector.

 28. Click the Outline color: swatch, and change the color to red.

 29. Click the OK button to rename the layer and update its properties.

 30. Verify that the Vector layer is above the Balloon 
layer in the Timeline panel. If not, drag and 
drop it at the top of the list. The order of the 
list from top to bottom determines the order 
of layers. The objects on a layer will obscure or 
hide all layers beneath.

 31. Turn off the visibility of the Balloon layer by 
clicking the dot in the column below the eye 
icon, as shown in Figure 4-4. The layer is not 
deleted, just hidden from view.

 32. Applying what you have learned, add the Hot 
Air Balloon image to the stage. The asset will be 
placed on the current layer, which should be the 
Vector layer.

New Layer

Goodheart-Willcox Publisher

Click to hide
the layer

Click to show
the layer

Figure 4-4. 

The visibility of a layer is turned on or off in the 
Timeline panel.



36 CORE Adobe Animate Creative Cloud

For individual use only—reproduction or duplication of this copyrighted material is prohibited.  Copyright Goodheart-Willcox Co., Inc.For individual use only—reproduction or duplication of this copyrighted material is prohibited.  Copyright Goodheart-Willcox Co., Inc.

 33. Make sure the image is selected. If not, click the 
Selection Tool button, and click the image to 
select it.

 34. Applying what you have learned, change the 
properties of the image to the same settings 
previously used. The image should be the same 
size and in the same location as the previous 
image.

 35. Click Modify>Bitmap>Trace Bitmap… on the 
Application bar. The Trace Bitmap dialog box is 
displayed, as shown in Figure 4-5.

 36. Click in the Color threshold: text box, and enter 125.

 37. Click in the Minimum area: text box, and enter 10. Lowering the minimum area 
will create a vector image with more clarity, but will substantially increase the 
fi le size. Setting the minimum area larger will create fewer vector shapes. This 
will make the image less detailed.

 38. Click the OK button to convert the image to a vector image.

 39. Click outside the image to deselect it and see the results. Notice the color 
differences that occur when a raster photograph is converted to a vector image.

 40. Click the Subselection Tool button, and click the edge of the balloon. Notice 
the individual shapes created when the vector image was created. Some of the 
larger shapes are visible with a solid fi ll.

 41. Click Undo action in the Edit pull-down menu or press the [Ctrl][Z] key 
combination. Do this as many times as needed to undo the tracing of the raster 
image.

 42. Applying what you have learned, trace the raster image again with a color 
threshold of 50 and a minimum area of 1000 pixels.

 43. Click the Subselection Tool button, and click the edge of the balloon. Notice 
how far less detail is preserved.

 44. Click the Selection Tool button, click outside the image to deselect it, and click 
any part of the dark blue sky. The upper part of the sky is now a single shape. 
Notice how only the dark blue is highlighted when it is selected.

 45. Click and drag the dark blue sky away from the balloon. Notice how the tracing 
operation converted the colors of the sky into a vector object.

 46. Press the [Delete] key to remove the dark blue sky.

 47. Applying what you have learned, delete the remaining sky and anything else 
not part of the balloon.

Replacing Color 
The fi ll color of a vector object can be easily changed. For the balloon, the fi ll colors 
will be adjusted to minimize the shadow on the right-hand side of the balloon.

 48. If needed, turn off the visibility of the Balloon layer so only the Vector layer is 
visible.

 49. Click the Selection Tool button, and click a dark red object on the right-hand 
side of the balloon. The dark red objects are in the shadow.

 50. Display the Properties panel.

TIP
The maximum 
value for the 
Minimum area: 
setting is 1000.

Subselection 

Tool

TIP
You can click and 
drag a selection 
box around an area 
containing vector 
objects to select all 
of those objects.

Goodheart-Willcox Publisher

Set the color
threshold

Set the minimum
area size

Figure 4-5. 

Creating a vector image by tracing a raster image.
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 51. Click the Fill Color color swatch, and click the color mixer button in the color 
palette that is displayed, as shown in Figure 4-6. The Color Picker dialog box is 
displayed.

 52. Click the value next to the R: radio button, and enter 165.

 53. Click the value next to the G: radio button, and enter 25.

 54. Click the value next to the B: radio button, and enter 5.

 55. Click the OK button to replace the fi ll color of the selected object. Notice how the 
object is now a lighter red, as if that area of the balloon is receiving full sun.

 56. Notice that there are two shades of red in the shadow, a lighter and a darker 
red. With the Selection Tool active, hold down the [Shift] key, and click each of 
the darker red areas on the right-hand side of the balloon. The [Shift] key allows 
multiple objects to be selected.

 57. Applying what you have learned, change the color of these darker red objects to 
R140, G25, B5.

 58. Applying what you have learned, change the color of the objects in the shadow 
as shown in Figure 4-7. When fi nished, the right-hand side of the balloon should 
be much lighter and not in shadow.

Obtaining Data from the Info Panel
Knowing the exact RGBA color settings for a single pixel can be helpful when 
deciding on a color to select or match. This information is reported in the Info 
panel. This information also can be used to identify any areas of the balloon with a 
specifi c color that have not been changed.

Goodheart-Willcox Publisher

Click to display
the color palette

Color mixer button

Color palette

Figure 4-6. 

Changing the fi ll color of a selected object.
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 59. Click Window>Info on the Application bar or click the collapsed Info panel to 
expand the panel.

 60. Move the cursor over the stripe on the balloon, and examine the RGBA values 
shown in the Info panel, as shown in Figure 4-8. Notice the alpha value (A:) is 
100%, which means the color at the cursor’s location is 100% opaque (not see-
through). The alpha channel controls opacity.

Color in 
Shadow

Replacement Color—Light Replacement Color—Dark

RGB Hex RGB Hex

Red R165, G25, B5 #A51905 R140, G25, B5 #8C1905

Orange R235, G35, B20 #EB2314 R200, G45, B10 #C82D0A

Yellow R200, G165, B50 #C8A532 R195, G130, B25 #C38219

Black R100, G85, B75 #64554B R70, G60, B50 #463C32

Goodheart-Willcox Publisher

Figure 4-7. 

The color settings for changing objects on the right-hand side of the balloon.

Goodheart-Willcox Publisher

Move the cursor
over the stripe

Click to display
the Info panel

Coordinate location
of the cursor

RGBA
values

Info
panel

Figure 4-8. 

The Info panel displays color and coordinate data about the cursor’s location.
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 61. Determine which blue in the stripe you like best, and note the RGBA value of 
that color.

 62. Applying what you have learned, change all objects in the stripe so the fi ll 
matches the blue you chose.

 63. Click outside the image to deselect it, and then click any object in the stripe. 
Notice how Animate has automatically joined all of the objects into a single 
object when all of the colors were changed to match.

 64. Applying what you have learned, display the color palette in the Properties 
panel for the stripe object, and click the Alpha: % setting, as shown in 
Figure 4-9.

 65. Change the setting to 50, and press the [Enter] key. The stripe is now 50 percent 
opaque. In this case, since the background is white, it looks like the color is 
lightened, but if another object were behind the stripe, it would be partially 
visible through the stripe.

Masking an Image
An image mask can be used to exclude parts of an existing image. The mask will 
reveal only the parts of the image that are covered by the mask.

 66. Applying what you have learned, turn off the visibility of the Vector layer and 
turn on the visibility of the Balloon layer.

 67. Applying what you have learned, create a new layer, and name it Mask.

 68. Applying what you have learned, position the Mask layer below the Vector layer, 
but above the Balloon layer.

 69. Click the Oval Tool button in the Tools panel.
Oval Tool

Goodheart-Willcox Publisher

Change the
alpha setting

Figure 4-9. 

Changing the alpha channel setting in the Properties panel.
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 70. Applying what you have learned, change the fi ll color to yellow with an alpha 
setting of 50%. By making the color semitransparent, you will be able to see 
through it to make the mask exactly where you want it.

 71. Click the Stroke Color color swatch in the Color panel, and click the no stroke 
swatch, as shown in Figure 4-10. This means the object will be drawn using 
only the fi ll color.

 72. Click and drag on the stage to draw an oval that covers most of the balloon. You 
will adjust the object later, so its size does not need to be exact at this point.

 73. Click the Subselection Tool button in the Tools panel, and click the edge of the 
oval. Handles are displayed on the oval, as shown in Figure 4-11.

 74. Drag the handles to distort the oval so it completely covers the balloon.

 75. Right-click on the Mask layer in the Timeline panel, and click Mask in the 
shortcut menu. All areas of the layers below the Mask layer that are not covered 
by the mask are blocked from view, as indicated by the layer names being 
indented under the Mask layer.

Adding Text
Text can be added to the stage to provide decoration or information. The kerning 
and tracking change the spacing of the characters, as shown in Figure 4-12. Kerning 
is the spacing between pairs of letters, such as A and V. Tracking is the spacing 
between all characters. Character alignment is the left-to-right position of a line 
of text. This can be aligned to the center, left, or right. Adobe Animate makes no 
distinction between kerning and tracking, instead collectively calling these letter 
spacing. Finally, lines of text can have the space between the lines changed. The 
spacing between lines of text is called leading. Leading can be increased to make 
more space between the lines of text. The Properties panel is used to modify the 
text.

TIP
If the oval does not 
appear, the image 
may be set to be 
on top. Select the 
image, and click 
Modify>Arrange> 
Send to Back on 
the Application bar.

Subselection 

Tool

TIP
To have a layer 
not affected by the 
mask, drag the layer
to the bottom of the 
indented stack, and 
then drag to the left 
until the black line 
is all the way to the 
left, and drop the 
layer. To make a 
layer affected by the 
mask, drag it into 
the indented stack.

Click to set the
stroke color

Click to remove
the stroke

Goodheart-Willcox Publisher

Figure 4-10. 

Removing the stroke color from an object.
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 76. Display the Vector layer, hide all other layers, and make the Vector layer current.

 77. Click the Text Tool button in the Tools panel, and click anywhere above the 
balloon. A text box is placed on the stage and active.

 78. Enter the text Balloons are Fun. Notice the text is 
in the current fi ll color and alpha setting.

 79. Click the Selection Tool button in the Tools 
panel, and then click the text box so it is 
selected.

 80. Click the Text Type drop-down arrow in the 
Properties panel, and click Static Text in the 
drop-down list.

 81. In the Position and Size area of the Properties 
panel, set the position to X = 150 and Y = 5.

 82. Set the width to 330.

 83. Click the Family: drop-down arrow in the 
Character area of the Properties panel, and click 
Broadway in the drop-down list. If this font is 
not available, choose any serif typeface.

Text Tool

Goodheart-Willcox Publisher

Drag Bézier handles
to change the curvature

Bézier
handle Handle

Figure 4-11. 

Adjusting the shape of an oval object to match the balloon shape by dragging the handles.

VARIABLE
Unaltered

VARIABLE
Kerning Adjusted

VA R I A B L E
Tracking Adjusted

Goodheart-Willcox Publisher
Figure 4-12. 

Kerning is the spacing between pairs of letters. Notice 
the positions of the V and the A. Tracking is the spac-
ing between all characters.
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 84. Click the Size: setting, and enter 36. This sets the size of the type in points, as 
shown in Figure 4-13.

 85. Click the Color: swatch, and change the color to #0000FF (blue) with an alpha 
setting of 100%.

 86. Click the Anti-alias: drop-down arrow, and click Anti-alias for readability in the 
drop-down list. This applies a form of antialiasing that is best for reading, as 
opposed to animated text.

 87. Click the Change Orientation button at the top of the Properties panel, and click 
Vertical, left to right in the drop-down menu.

 88. Applying what you have learned, change the height of the text box to 600. Notice 
how the words read up and down instead of left and right.

 89. Applying what you have learned, change the orientation of the text to horizontal 
and the width of the text box to 330.

 90. Activate the Text Tool, click before the letter F in Fun, press the [Backspace] key 
to remove the space between are and Fun, and press the [Enter] key to move the 
word Fun to a new line below Balloons are.

Change 

Orientation

Goodheart-Willcox Publisher

Text
properties

Text is
added

Click to rotate
the text

Figure 4-13. 

Adding text and changing its properties.
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 91. With the Text Tool active, click and drag over Balloons are Fun to select the text.

 92. Click Text>Align>Align Center on the Application bar.

 93. Select the oo character pair in the word Balloons.

 94. Click Text>Letter Spacing>Increase on the Application bar to increase the 
kerning between the selected letters.

 95. Select the ll letter pair in the word Balloons.

 96. Expand the Character area of the Properties panel, click the value to the right of 
Letter spacing:, and enter .4. This increases the kerning and has the same effect 
as clicking Text>Letter Spacing>Increase on the Application bar.

 97. Select the word Balloons.

 98. Expand the Options area of the Properties panel, click in the Link: text box, and 
enter http://www.balloons.com as the URL. This makes the text a hyperlink.

 99. Click in the Target: text box, and enter _blank. An entry of _blank will open the 
link in a new browser tab or window.

 100. Activate the Selection Tool, and click the text box to select it.

 101. Click Text>Check Spelling on the Application bar, and spell-check the text box. 
Note: the spell-checker was deprecated (eliminated) in the initial release of 
Adobe Animate CC. Depending on how up-to-date your version is and whether 
or not Adobe has reinstated this feature, you may or may not have it available.

Adjusting Color Effects
To this point, you have worked with basic color properties. Other color settings, 
such as tint and brightness, can be changed as well.

 102. Right-click on the Balloon layer in the Timeline panel, and click Duplicate Layers 
in the shortcut menu. This creates an exact copy of the layer. The duplicate layer 
is named Balloon copy.

 103. Rename the Balloon copy layer as Colors, place it at the top of the layer stack, and 
make it visible. Note that since it is no longer below the Mask layer, the mask 
will not affect it.

 104. Click the lock icon for the Colors layer in the Timeline panel to unlock the layer.

 105. Hide all layers other than the Colors layer.

 106. Select the balloon image on the Colors layer.

 107. Click Modify>Convert to Symbol… on the 
Application bar. The Convert to Symbol dialog 
box is displayed, as shown in Figure 4-14. 

 108. Click in the Name: text box, and enter movie_
balloon.

 109. Click the Type: drop-down arrow, and click 
Movie Clip in the drop-down list.

 110. Click the center box in the Registration: area to 
set the origin of the object.

 111. Click the OK button to convert the image to a 
movie clip.

 112. Expand the Color Effect section in the 
Properties panel.

TIP
The text alignment 
can also be set in 
the Paragraph area 
of the Properties 
panel.

TIP
When a layer is 
current, a pencil 
icon appears next 
to its name in the 
Timeline panel. If 
the layer is locked, 
the pencil icon 
will have a slash 
through it.
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Select the type
of symbol
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origin

Name the symbol

Figure 4-14. 

Converting a raster image into a movie clip symbol.
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 113. Click the Styles: drop-down list, and examine the different color effects 
available.

 114. Click Alpha in the drop-down list, click in the Alpha: text box that is displayed, 
and enter 50.

 115. Applying what you have learned, change the tint setting to 20% with a red 
value of 0, green value of 200, and blue value of 0.

 116. Turn on the visibility of the Balloon layer.

 117. Toggle the visibility of the Colors layer to see the changes from the original 
image on the Balloon layer and the adjusted image on the Colors layer. Notice 
the effect of the color effect adjustments. The image on the Colors layer looks 
like an aged photograph.

 118. Save your work.

Publishing in Other Formats
Animate fi les can be saved in a number of formats. The fi le saved in the previous 
section is an Animate document in FLA format. This is the native fi le format for 
Animate. When creating an Animate project, use the native fi le format. When the 
project is completed, it can be saved in a format that is compatible with various 
multimedia platforms, such as HTML 5 canvas, WebGL, AIR, and video formats. 
Another type of fi le is OAM, which is an Animate deployment package that packs 
all the necessary assets into a folder. SWF, which is generally pronounced swif, 
is a vector-graphic animation format. This is a legacy format still supported for 
compatibility with existing multimedia platforms, such as websites.

 119. Turn on the visibility of all layers, and arrange them in this order from top to 
bottom: Mask with Balloon indented below it, Vector, and Colors. The Vector and 
Colors layers should not be indented under the Mask layer so they will not be 
affected by the mask. This produces an image with the masked balloon image 
on top, the text visible, and the tinted sky visible, as shown in Figure 4-15.

 120. Toggle the visibility of each layer to see how the image is assembled.

 121. Click File>Publish on the Application bar. Two fi les are saved in the same folder 
where the FLA fi le is stored: SWF and HTML. The HTML fi le is created so the 
SWF can be viewed in a web browser.

 122. Using the system fi le explorer, navigate to your working folder. Notice there are 
three LastName_Balloon fi les in the folder.

 123. Hover the cursor over each of the LastName_Balloon fi les to display the help text. 
If the system is set up to display fi le extensions, you will not need to display the 
help text for a fi le to determine its type.

 124. Double-click on the LastName_Balloon.html fi le to open it in the default web 
browser. If a message is displayed warning of ActiveX content, allow the 
content to be displayed.

 125. Click the word Balloons, which is the hyperlink you created. A new browser tab 
or window is opened, and the www.balloons.com website is displayed.

 126. Close both tabs or browser windows.

 127. Double-click on the SWF fi le to open it in the Adobe Animate Player installed 
on your computer. If asked to select an application to use, select a web browser 
in the list that is offered. If the web browser displays a message that ActiveX is 
blocked, choose to enable the content.

TIP
If the mask does 
not appear to be 
working correctly 
after rearranging 
the layers, try 
removing the mask 
by right-clicking on 
the Mask layer and 
unchecking Mask in 
the shortcut menu 
and then reapplying 
the mask to the 
Balloon layer.
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 128. Click the hyperlink Balloons are Fun. A new 
browser window is opened, and the www.
balloons.com website is displayed.

 129. Close the player and the web browser. Leave 
the Animate open.

 130. In Animate, click Commands>Convert To 

Other Document Formats on the Application 
bar. The Document Type Converter dialog box 
is displayed, as shown in Figure 4-16.

 131. Click the drop-down arrow, and click HTML 

5 Canvas in the drop-down list. This will 
convert the document to an HTML 5 canvas 
document. This is one of the document types 
that can be selected when a new Animate 
document is created.

 132. Click in the Save As: text box. Notice the default location for the new document 
is the save location where the current document is saved and the fi le name is 
the same appended with _Canvas.

Goodheart-Willcox Publisher

Vector layer

Mask layer
with the Balloon

layer visible

Colors layer

Figure 4-15. 

The layers are all visible, and their order has been adjusted to show and hide various features.

Select the
document type

Select the
location and
file name
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Figure 4-16. 

Converting an Animate document into an HTML 5 
canvas document.
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 133. Click the OK button to convert the document. A new document tab is opened 
displaying the converted document.

 134. Applying what you have learned, publish the new document. Since this 
document type is an HTML 5 canvas, publishing creates an HTML fi le and a 
JavaScript fi le (.js).

 135. Using the system fi le explorer, double-click on the LastName_Balloon_Canvas.
html fi le. The balloon image is displayed in the browser. However, the hyperlink 
likely will not work. This is because the document-conversion process does not 
always create correctly functioning output. If the intended output is an HTML 5 
canvas, always begin the project with an Animate HTML 5 canvas document 
type.

 136. In Animate, close the LastName_Balloon_Canvas document tab, and leave the 
LastName_Balloon document open.

 137. Click File>Publish Settings… on the Application bar. The Publish Settings 
dialog box is displayed, as shown in Figure 4-17. The items checked in the 
list on the left tell Animate which types of fi les to create when the Publish 
command is used. Notice the HTML Wrapper and Flash (.swf) check boxes 
are checked. These are the two fi les that were created when you previously 
published this document.

Check to create a
deployment package

Goodheart-Willcox Publisher

Figure 4-17. 

A deployment package is created when the document is published if the OAM Package check box is checked in 
the Publish Settings dialog box.
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 138. Check the OAM Package check box. This tells Animate to create a deployment 
package the next time the Publish command is used.

 139. Click the Publish button to publish the document.

 140. Click the OK button to save the settings and close the Publish Settings dialog 
box.

 141. Using the system fi le explorer, navigate to your working folder. Notice there is 
now an OAM fi le as well as a subfolder named images. The subfolder contains 
the HotAirBalloon.png image fi le, which is the only asset used in the Animate 
document.

 142. Save your work, and close Animate and all other windows.

Lesson Review

Vocabulary
In a word processing document or on a sheet of paper, list all of the key terms in 
this lesson. Place each term on a separate line. Then, write a defi nition for each 
term using your own words. You will continue to build this terminology dictionary 
throughout this certifi cation guide.

Review Questions
Answer the following questions. These questions are aligned to questions in the 
certifi cation exam. Answering these questions will help prepare you to take the exam.

 1. List two different ways to change the stage size.

 ___________________________________________________________________________________

 ___________________________________________________________________________________

 2. Which tool or panel of the interface is used to change the X or Y coordinate of 
an object?

 ___________________________________________________________________________________

 ___________________________________________________________________________________

 3. Briefl y describe how to trace a raster image to create a vector image.

 ___________________________________________________________________________________

 ___________________________________________________________________________________

 ___________________________________________________________________________________

 ___________________________________________________________________________________

 4. What are two ways of renaming a layer?

 ___________________________________________________________________________________

 ___________________________________________________________________________________

 ___________________________________________________________________________________

 ___________________________________________________________________________________
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 5. How is the fi ll color of a selected object changed?

 ___________________________________________________________________________________

 ___________________________________________________________________________________

 ___________________________________________________________________________________

 ___________________________________________________________________________________

 6. What does the alpha channel setting control?

 ___________________________________________________________________________________

 7. Which panel displays the RGBA values and the coordinates at the cursor’s 
location?

 ___________________________________________________________________________________

 8. How is a layer turned into a mask? 

 ___________________________________________________________________________________

 ___________________________________________________________________________________

 ___________________________________________________________________________________

 ___________________________________________________________________________________

 9. Describe the difference between tracking and kerning, and explain the 
difference as applied in Animate.

 ___________________________________________________________________________________

 ___________________________________________________________________________________

 10. Which term describes the space between lines of text?

 ___________________________________________________________________________________

 11. How is the spell-checker launched in Animate?

 ___________________________________________________________________________________

 12. In which area of the Properties panel is a hyperlink added to text?

 ___________________________________________________________________________________

 13. Briefl y describe how to add a yellow tint to a movie clip symbol (object).

 ___________________________________________________________________________________

 ___________________________________________________________________________________

 ___________________________________________________________________________________

 ___________________________________________________________________________________

 14. What type of fi le is Movie.oam?

 ___________________________________________________________________________________

 15. Briefl y describe how to convert an Animate document into an HTML 5 canvas 
document.

 ___________________________________________________________________________________

 ___________________________________________________________________________________

 ___________________________________________________________________________________

 ___________________________________________________________________________________
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Answers

Lesson 1
 1. Shape, form, line, color, value, space, and texture.

 2. Regular shapes and objects that are used to 
assemble more complex shapes or objects.

 3. The primary colors of red, blue, and yellow.

 4. A complementary color is located opposite of 
the selected color on the color wheel, while an 
analogous color is located next to the selected 
color.

 5. Positive space is the area or volume occupied by 
the primary objects, while negative space is the 
area or volume around or between the primary 
objects.

 6. The point or points in a perspective drawing 
where receding parallel lines appear to meet.

 7. Movement, emphasis, harmony, variety, balance, 
contrast, proportion, pattern, and unity.

 8. Movement.

 9. Emphasis.

 10. Balance.

 11. An image is divided into three sections 
horizontally and three sections vertically to 
create nine areas, and where the lines cross are 
the focal points for a scene.

 12. Contrast.

 13. Unity.

 14. To achieve site-wide consistency.

 15. Shorter development time, easier maintenance, 
and improved usability.

Lesson 2
 1. RGB

 2. CMYK

 3. It is the total spectrum a given color model can 
produce.

 4. Bit depth of 8.

 5. The alpha channel allows for a masking 
color, which is a single shade of a color that 
determines areas of transparency in the image.

 6. Vector.

 7. The process of converting a raster image into a 
vector image.

 8. Raster images are composed of colored dots 
at specifi ed locations, while vector images 

are composed of elements recorded by their 
mathematical defi nitions.

 9. Applying the most appropriate resolution and 
fi le compression.

 10. Download it from a digital camera.

 11. The image is dithered, and the software creates 
a color through interpolation.

 12. 576

 13. Bicubic for enlargement.

 14. A serif font has decorations called serifs at the 
ends of letters, while a sans serif font lacks these 
decorations.

 15. Sans serif.

Lesson 3
Figure 3-2

 1. Selection Tool

 2. Subselection Tool

 3. Free Transform Tool

 4. 3D Rotation Tool

 5. Lasso Tool

 6. Eraser Tool

 7. Stroke Color

 8. Swap Colors

 9. Delete Anchor Point Tool

 10. Oval Tool

 11. PolyStar Tool

 12. Paint Brush Tool
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 13. Pen Tool

 14. Text Tool

 15. Line Tool

 16. Fill Color

 17. Pencil Tool

 18. Hand Tool

 19. Rectangle Tool

 20. Add Anchor Point Tool

 21. Convert Anchor Point Tool

 22. Rectangle Primitive Tool

 23. Ink Bottle Tool

 24. 3D Translation Tool

 25. Brush Tool

 26. Width Tool

 27. Bone Tool

 28. Paint Bucket Tool

 29. Eyedropper Tool

 30. Zoom Tool

 31. Black and White

 32. Gradient Transform Tool

 33. Bind Tool

 34. Oval Primitive Tool

Figure 3-3
 1. Snap to Objects

 2. Straighten

 3. Paint Selection

 4. Object Drawing

 5. Erase Normal

 6. Faucet

Review Questions
 1. The layout of the toolbars, panels, and document 

on the screen.

 2. A small window that holds commands or options.

 3. The Timeline panel.

 4. The stage is the area where the on-screen action 
is displayed, while anything on the pasteboard 
will not appear in the fi nal output.

 5. The scene bar above the pasteboard.

 6. By clicking the document tab of the document to 
display.

 7. By clicking Reset ‘workspace name’ in the drop-
down menu displayed by clicking the workspace 
switcher button.

 8. Click the Subselection Tool button in the Tools 
panel.

 9. At the bottom of the Tools panel.

 10. A fl yout is a toolbar that contains additional 
tools and is indicated by a black triangle at the 
bottom-right corner of a tool.

 11. Drag the Project panel and drop it in the panel 
group next to the Library panel.

 12. Click New Workspace in the workspace switcher, 
and enter the name Alignment.

 13. Swatches

 14. Rectangle

 15. How it is drawn. If it closely matches a circle, it 
will be converted into a circle, otherwise it will 
be converted into an ellipse.

Lesson 4
 1. Either by changing the document size 1) in 

the Document Settings dialog box, or 2) in the 
Properties panel.

 2. The Properties panel.

 3. Select the image, click Modify>Bitmap>Trace 

Bitmap…, and set the color threshold and 
minimum area.

 4. A) Right-click on the layer in the Timeline panel, 
click Properties in the shortcut menu, and 
change the name in the Layer Properties dialog 
box. B) Double-click on the layer name in the 
Timeline panel to make the name editable.

 5. Click the Fill Color color swatch in the Properties 
panel, and select a color in the palette that is 

displayed or click the color mixer button to 
defi ne a color in the Color dialog box.

 6. The opacity of the object to which the color is 
applied.

 7. The Info panel.

 8.  Right-click on the layer in the Timeline panel, 
and click Mask in the shortcut menu. Any layers 
in the stack below that layer will be masked.

 9. Kerning is applied to select letter pairs, while 
tracking is applied to entire words or lines of text. 
Animate does not make a distinction between 
kerning and tracking, calling both letter spacing.

 10. leading

 11. Click Text>Check Spelling on the Application bar.
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 12. The Link: text box is located in the Options area 
of the Properties panel.

 13. In the Color Effect area of the Properties panel, 
click Tint in the Style: drop-down list, and adjust 
the Red:, Green:, Blue:, and Tint: sliders to the 
color and level desired.

 14. Animate deployment package

 15. Click Commands>Convert To Other Document 

Formats on the Application bar, and select the 
HTML 5 canvas document type in the Document 

Type Converter dialog box.

Lesson 5
 1. To create interactive and expressive content for 

multiple platforms.

 2. AIR for Android

 3. Make Responsive

 4. 12

 5. easing

 6. The onion skin.

 7. Action is defi ned on keyframes, and Animate 
creates the tweens to fi ll in the action between 
the keyframes.

 8. keyframe

 9. Shape tweening, because the object is gradually 
changed from one basic shape on the fi rst 
keyframe to another shape on the next keyframe.

 10. motion tweening

 11. To keep motion tweens on layers separate from 
other shapes.

 12. motion path

 13. Symbols are the building blocks of animations 
because they are reusable objects such as 
graphics, buttons, and movie clips.

 14. Individual bones are rigged to create the skeleton, 
each bone is assigned a range of motion and a 
pivot point, and the bones are attached to the 
objects that compose the character.

 15. The movement of the parent object controls the 
movement of the child object and vice versa.

 16. By copying the code for the animation as a snippet 
and then pasting the snippet where needed.

 17. It contains objects that are not animated, such as 
the background, and requires only one frame.

 18. blue

 19. light green

 20. The playhead indicates the current frame in the 
animation; it moves across the timeline during 
animation playback and can be dragged to 
manually preview the animation.

 21. Two seconds.

 22. One-half second.

 23. Rich media that contains both video and audio.

 24. The change to the symbol is automatically 
applied to all instances of the symbol.

 25. Web browser in use, operating system of the 
device, and screen resolution of the device.

Lesson 6
 1. The thickness of a line.

 2. Click the Lock corner radius controls to one 

control (chain link) button in the Rectangle 

Options area of the Properties panel so the 
button is on, and then enter the radius in the one 
active text box.

 3. The X value increases to the right of the stage, 
while the Y value increases to the bottom of the 
stage.

 4. The Subselection Tool.

 5. The black dot means the frame is a keyframe, 
blue means motion tweening, and green means 
shape tweening.

 6. Straight-ahead (frame-by-frame) animation.

 7. Previewing the animation in Animate, because 
only the stage is included in the compiled 
animation output.

 8. Click Control>Play on the Application bar or 
drag the playhead.

 9. On the fi rst frame of the motion, right-click on 
the object, select Create Motion Tween in the 
shortcut menu, move to the last frame of the 
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motion, and drag the object to the new location. 
The motion path is automatically created, with 
one node on each tween.

 10. The fi le size will be reduced.

 11. The motion of the object is changed.

 12. With the Subselection Tool active, hold down 
the [Alt] key (or [Option] key on a Mac), and click 
either node.

 13. In the motion editor, click the Add Ease button, 
then choose the type of easing to apply in the 
menu.

 14. By double-clicking on the tween to edit.

 15. Drag and drop the layers into the folder.

 16. Shape tweening.

 17. Click View>Guides>Edit Guides… on the 
Application bar, and then click the Color: color 
swatch in the Guides dialog box.

 18.  Drag the guideline and drop it on the ruler.

 19.  The text must be broken apart twice.

 20. GIF

Lesson 7
 1. Identify the target audience and set the client 

goals.

 2. think, learn, design, and build

 3. Sketches, a statement of deadlines and 
milestones, defi nition of the project scope, and 
detailed project specifi cations.

 4. task chart and specifi cations

 5. Compatibility with Animate, format and size, 
and amount of rich media.

 6. fi nancial budget and time budget (or client 
timeline)

 7. A storyboard is a graphical representation of an 
intended visual process that is used to visualize 
graphic sequences and the user interface.

 8. A storyboard is a planning tool that uses 
sketches to show how items move in an 
animation.

 9. Determine if it helps meet the business 
requirements of the project.

 10. It is a tool that helps store and organize assets 
used between Adobe products.

 11. It is important to meeting the deadline, helps 
improve usability of the output, and makes 
maintenance easier.

 12. It results in an aesthetically pleasing design and 
helps streamline the process.

 13. Reusing assets leads to consistency, which in 
turn reduces the total size of the project because 
there are fewer assets.

 14. With antialiasing using the Antialias for 

Readability setting.

 15. It allows the screen reader to state a description 
of the image.

 16. Properties panel

 17. Ensure enough white space is provided, 
overlapping content is avoided, a readable font is 
used, and the text is set in an appropriate size.

 18. Provide high contrast by using a light color for 
the text.

 19. [Alt] and [Tab]

 20. Avoid including animated text or images.

 21. The material has no restrictions on use.

 22. The fair use doctrine.

 23. It is the letter C contained within a circle.

 24. As soon as it is in tangible form.

 25. An idea cannot be copyrighted; the material 
must be in tangible form.

 26. Performance testing in which the user is 
recorded and has screen movements tracked as 
he or she uses the software.

 27. Movie_Apples_mc

 28. Observe, survey, or interview members of the 
target audience.

 29. Links, scripts, buttons, and rich content.

 30. An informal audience is friends and coworkers 
who help test usability during the design 
process. A focus group is made up of members 
of the target audience who are evaluated using 
a sight study to test usability. Beta testers 
are members of the target audience who 
test a live version of the product and report 
errors. Evaluating accessibility involves target 
audience members who have real or simulated 
impairments and who test for performance and 
functionality.
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Lesson 8
 1. Click the panel menu button in the Color panel, 

and click Add Swatch in the menu.

 2. Exported by clicking the panel button menu in 
the Swatches panel and clicking Save Colors… 
in the menu.

 3. Angling the sides of a rectangle and shortening 
the side farthest from the viewer.

 4. Snap to Pixels

 5. The Motion Presets panel.

 6. Dragging the play head to preview the animation.

 7. The animation is compressed or expanded.

 8. The fi le size will be smaller while maintaining 
the audio quality.

 9. Remove the head and tail and compress the audio.

 10. Create a new layer for the sound, add a 
keyframe for the frame on which the sound will 

begin, and drag the sound asset from the Library 
panel to the stage.

 11. Select the fi rst frame of the waveform in the 
Timeline panel, and in the Properties panel click 
the Effect: drop-down arrow and select the 
effect.

 12. An event sound must be fully downloaded 
before it begins playing, while a streaming 
sound will begin to play as it is downloaded.

 13. Click File>File Info… on the Application bar, and 
then add the metadata in the dialog box that is 
displayed.

 14. Click Control>Test Movie>In Animate or 
Control>Test Movie>In Browser on the 
Application bar.

 15. Exporting (File>Export>Export Video…)

Lesson 9
 1. TimerEvent

 2. An integer is a number without decimal points, 
while a number can include a fl oat or numbers 
after a decimal.

 3. string

 4. array

 5. Click Debug>Debug Movie>In Animate on the 
Application bar. If there are any errors, the 
Compiler Errors panel is displayed; otherwise, 
the animation is previewed.

 6.  Animate.events

 7.  TimerEvent

 8.  myTimer

 9.  event:TimerEvent

 10.  var

 11.  A variable.

 12.  Uploads the variable data to a server.

 13. It closes the function and returns no value so 
Animate stops looking for a value.

 14. timerFunction

 15. addEventListener

Lesson 10
 1. In the User Interface folder on the Components 

panel.

 2. It identifi es the object as a button that, when 
clicked, begins some action, such as starting a 
game or playback.

 3. The enable and visible check boxes in the 
Component Parameters area of the Properties 
panel must be checked.

 4. Apply the alpha color effect to the button fi ll 
color, and change the alpha value to less than 
100%, such as 50%.

 5. Over (changes from up to over).

 6. Over (changes from up to over).

 7. In the keyframe for the correct button state.

 8. The method and parameter gotoAndStop(1) will 
return the movie to Frame 1 and stop playback. 
The user then must click the Play button, which 
must be properly programmed, to resume 
playback.

 9. Custom

 10. Place the cursor at the point in the code where 
the snippet is to be inserted, display the Code 

Snippets panel, select the snippet, and click the 
Add to current frame button.
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